Contents

Introduction...............................................................................................6
   About WPS...............................................................................................6
   WPS and SAS® software..........................................................................7
   WPS components....................................................................................8

Getting started........................................................................................10
   Workspace Launcher................................................................................10
   Welcome pages.......................................................................................11
   Migrating existing programs or projects................................................11
      Migrating from previous versions of WPS........................................11
      Migrating from SAS® software.........................................................11
   Code Analyser.......................................................................................12
   Import a project.....................................................................................16
   Workbench layout................................................................................16
      Default WPS perspective.................................................................16
   Online help..........................................................................................17
   Cheat sheets.........................................................................................18

WPS server.............................................................................................21
   Configure a local WPS installation.........................................................21
   Default WPS server............................................................................23
   WPS server LOCALE and ENCODING settings...............................23
      General text file encoding...............................................................24
   Licence key..........................................................................................25
      Apply a licence key........................................................................25
   Database connectivity........................................................................26
      Connect to Oracle............................................................................26
      Connect to DB2...............................................................................28
      Connect to SQL Server....................................................................29
      Connect to MySQL..........................................................................30
      Connect to a database using ODBC..............................................32
   Restart the server................................................................................33

Views and perspectives...........................................................................34
   Project Explorer..................................................................................34
      Projects............................................................................................35
      Local history...................................................................................40
      Switching to a different workspace..............................................43
   File Explorer......................................................................................43
Libraries and datasets ........................................................................... 76
Run a program ....................................................................................... 71
Create a new program ........................................................................... 67

Create a new program............................................................................. 67
Creating a new program file in a project.................................................. 68
Entering WPS code via templates............................................................. 69
WPS Code Injection.................................................................................. 69
Using Program Content Assist................................................................. 69
WPS syntax colouring............................................................................... 70

Run a program....................................................................................... 71
Run a program in Workbench................................................................. 71
Run part of a program............................................................................. 71
Stop program execution........................................................................ 72
WPS Preferences for running programs................................................... 72
Command line mode............................................................................... 74

Libraries and datasets........................................................................... 76
Set WORK location...................................................................................................................... 76
Catalogs........................................................................................................................................77
Datasets........................................................................................................................................78
  Import datasets..................................................................................................................78
  Export datasets.............................................................................................................81
  Remove dataset reference..........................................................................................81
  **Data Profiler view**....................................................................................................82
  Dataset Viewer.............................................................................................................91

**Working with program output**.......................................................................................... 98
  Dataset generation............................................................................................................ 98
  Logs....................................................................................................................................... 99
  View the log....................................................................................................................... 99
  Save the log to a file....................................................................................................... 99
  Print the log....................................................................................................................... 99
  Log colouring preferences..............................................................................................100
  Managing ODS output.......................................................................................................100
    Automatically manage ODS destinations...................................................................100
    Listing output...............................................................................................................101
    HTML output...............................................................................................................102
    PDF output..................................................................................................................104
    Clearing the results output.........................................................................................105

**Text-based editing features**.......................................................................................... 106
  Working with editors.........................................................................................................107
    SAS Editor....................................................................................................................107
    Text Editor..................................................................................................................108
    System Editor.............................................................................................................108
    In-Place Editor...........................................................................................................108
    Text Editor Preferences.............................................................................................109
    Closing files................................................................................................................109
  Jumping to a particular project location..........................................................................109
  Navigation between multiple project files......................................................................110
  Searching and replacing..................................................................................................110
  Undoing and redoing your edits.....................................................................................111

**Preferences**.................................................................................................................... 112
  General preferences.........................................................................................................112
  Change shortcut key preferences....................................................................................113
  Back up Workbench preferences....................................................................................113
  Import Workbench preferences.....................................................................................114

**Configuration files**........................................................................................................115
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>AutoExec file</td>
<td>118</td>
</tr>
<tr>
<td>WPS Tips and Tricks</td>
<td>119</td>
</tr>
<tr>
<td>Troubleshooting</td>
<td>121</td>
</tr>
<tr>
<td>Making technical support requests</td>
<td>122</td>
</tr>
<tr>
<td>Legal Notices</td>
<td>123</td>
</tr>
</tbody>
</table>
Introduction

This guide is intended to help you gain familiarity with the SAS language programming environment through WPS Workbench, the graphical user interface of WPS (the World Programming System). The Workbench SAS Language Environment enables you to create, edit and run SAS language programs, and view the resulting dataset, logs and other output.

WPS Workbench also contains the Workflow Environment – a drag-and-drop workflow editor and data profiling tool ideal for data mining or predictive modelling tasks. For more information, see the WPS Workflow Environment Perspective User Guide.

The user guide does not aim to:

- Train you in the use of the SAS language. If you are not already familiar with this language, there is a wide range of educational and reference material available from many sources.
- Teach you every option within WPS. However, once you have worked through this guide you should be sufficiently familiar with the system to run some basic programs and to begin processing and analysing data.

For an overview of some commonly-used features, see Tips and tricks (page 119), and for information to help you resolve some previously-reported problems see troubleshooting (page 121).

About WPS

The World Programming System (WPS) consists of the following components:

- An Integrated Development Environment (IDE) – WPS Workbench. This environment utilises the Eclipse IDE as the basic framework to provide the graphical user interface. The IDE provides facilities to manage, create and edit SAS language programs, and then to run these programs using the WPS server.
- A compiler/interpreter – WPS server. When using WPS Workbench, the compiler is run as a server process and is used to process and execute programs. The compiler is also used when running WPS from the command line (CLI), sometimes referred to as running WPS in batch mode.

WPS server process

To run SAS language programs, WPS Workbench requires a connection to a licensed WPS server process (for more information, see WPS server (page 21)). This process may be running either on the local workstation (a local server), or on an installation of WPS on a remote machine (a remote server).
Eclipse IDE

Eclipse is an open source tool that provides an environment for editing and managing files and tasks. It is designed to accommodate plug-ins to perform specific tasks, for example the plug-ins designed to aid SAS language program development supplied as WPS Workbench.

WPS intentionally leaves the Eclipse environment open for advanced users to add in other third party tools and facilities. Consequently, WPS Workbench includes some unused features that allow other Eclipse-based plug-ins and extensions.

Some of the features mentioned in this guide are built-in features of Eclipse, but are referred to as features of WPS for simplicity.

WPS and SAS® software

If you are accustomed to using other products related to the SAS language, you will find that the language support in WPS is familiar. You can expect to find much of the same syntax in terms of procedures, formats, macros, DATA steps, and so on.

WPS provides other recognisable features and objects such as logs, datasets, or the Work library. Other features may be new to you, such as the Workbench environment itself and the way in which it handles or displays objects. You will find that the Workbench has help and reference material to assist you in migrating to WPS.

Compatibility with SAS® software

Besides being able to run, modify, share and save programs written in the SAS language, WPS is also able to read from and write to data files used by SAS software. WPS also includes a wide selection of library engines to allow you to access many leading third party databases, data warehouses and Hadoop big data environments.

WPS also uses a proprietary dataset file format known as WPD. As the default dataset library engine, WPD datasets are used for the Work library. Because it is the dataset library engine that is native to WPS, it has the most complete feature support, including, for example, indices.

Supported language elements

WPS does not yet support every element in the SAS language. The Workbench provides a code analysis tool (see code analyser (page 12)) to help determine if any of your existing SAS programs contain unknown language elements. Details of the SAS language elements currently-supported in WPS can be found in the WPS Reference for Language Elements.

Existing SAS programs

WPS uses SAS language program, or program to describe scripts, programs and applications written in the SAS language.
WPS components

This section gives brief descriptions of the objects managed by the Workbench.

Projects
The fundamental unit of organisation for SAS language programs and related objects. For example, you might have a project for applications under development, or another for monthly reporting jobs. For more information, see Projects (page 35).

SAS language programs
Create or modify SAS language programs using the SAS language editor. Files containing SAS language programs use either .wps or .sas extensions. For more information see SAS language editor (page 107).

Log output
When you run a SAS language program, the information generated is stored in the log file. This file can be viewed, printed and saved from within the Workbench. The log generated is cumulative and contains the results of each program run since opening WPS Workbench, restarting the WPS Server, or clearing the log. For more information, see Logs (page 99).

Listing output
This contains the printed output from any programs that you have run. For example, this could be a table of data generated by a PROC PRINT statement. Listing output can be viewed, printed and saved in the Workbench. The listing output generated is cumulative and contains the output of each program run since opening WPS Workbench, restarting the WPS Server, or clearing the listing output. For more information, see Listing output (page 101).

ODS output
As described, the ODS (Output Delivery System) can be used to produce text listing and HTML output. Each program can specify when and where its output is stored but it is also possible to allow the Workbench to manage the process automatically. The default option is for the Workbench to generate HTML output. For more information see Managing ODS output (page 100).

Datasets
The data generated from running a program is stored in datasets. You can either browse or edit a dataset using the dataset viewer. For more information, see Datasets (page 78).

Host Connection
A computer, local or remote that Workbench can access. The local host connection enables you to run SAS language programs on the WPS server installed on your local machine. Connections can also be made to remote WPS servers, see Connect to a remote WPS server (page 48) for more information.
**WPS server**

Executes SAS language programs and generates the resulting output, such as the log, listing output, results files, and datasets. The WPS server maintains an environment of assigned libraries, macros and macro variables, and so on, with which all of the running programs interact. For more information, see *WPS server* (page 21).
Getting started

Workspace Launcher

When you open WPS Workbench, the Eclipse Launcher dialog box is displayed.

A workspace is the parent folder used to hold one or more projects (page 35). It is possible to use any folder on any drive that your computer can access, as a workspace, and the workspace you use is the default location for newly-created projects.

You do not have to use projects to manage your Workbench resources; any files you can access – on your local system or a remote computer can be accessed in Workbench through the File explorer (page 43).

On Windows, the default location of the workspaces is your My Documents folder, and, on UNIX and Linux platforms, it is your home directory. In all cases, the sub-directory is called WPS Workspaces and the workspaces are named incrementally, starting at Workspace1.

To use a different workspace either select the name in the Workspace list, select a workspace from the Recent Workspaces list, or click Browse and navigate to the workspace folder in the Select Workspace Directory dialog box.

The Eclipse Launcher dialog box is displayed whenever you start Workbench. To hide the dialog box at start up and use the selected workspace every time you start Workbench, select the Use this as the default and do not ask again check box.
Welcome pages

The Welcome pages display introductory information about WPS Workbench. The default Get Started page is designed to help you start using WPS Workbench as quickly as possible. This page also displays a number of links to other welcome pages, including our website.

Closing and re-opening the welcome pages

To close the welcome pages and start using the Workbench without further guidance, click Close on the Welcome tab.

To reopen the welcome pages, click the Help menu and then click Welcome.

Migrating existing programs or projects

This section describes how to use existing projects or SAS language programs with the latest version of WPS.

Migrating from previous versions of WPS

Workspaces opened with previous versions of WPS can be opened with the current version, so there are no migration steps to be performed to use a workspace from a previous version of WPS with the latest version. However, the first time that you open a workspace that was created using an earlier version of WPS, an Eclipse dialog is displayed asking for your confirmation that it is OK for the workspace to be upgraded automatically. Such automatic upgrades should not cause any problems.

Existing SAS programs do not need to be modified to work with the latest version of WPS. In addition, projects that were created with earlier versions of WPS can be opened and used by later versions of WPS without any additional action.

Migrating from SAS® software

If you already have programs written in the SAS language, there is no conversion process to undertake in order to use these programs with WPS. Any file with the .wps or .sas extension is assumed to be a program that the Workbench can open, edit and run.

Accessing your existing programs

You can access your existing programs from the File Explorer view.
Alternatively, you can use Workbench projects, to manage your files enabling you to use other features such as local history.

Checking program compatibility

Opening programs in the Workbench causes unknown or unsupported language elements to be displayed in red. However, before trying to execute your existing programs in WPS, it is also recommended that you use the Workbench Code Analyser (page 12) for further verification.

Analysing programs, even hundreds of programs at a time, can take less than a few minutes to complete and can therefore be quicker than trying to execute long-running programs. Program analysis is available from both the File Explorer view or the Project Explorer view.

Code Analyser

Use the Workbench Code Analyser to scan the code of existing programs written in the SAS language.

The Code Analyser is a feature of the Workbench and can therefore only be used on platforms on which Workbench is supported. The Code Analyser generates reports that indicate which of your existing programs will run unchanged in WPS, which programs may require modification to run, and which programs contain language elements not yet supported by WPS.

The Code Analyser allows you to:

- **Analyse Program Compatibility** – whether your existing programs or projects contain any unsupported language elements.
- **Analyse Language Usage** – lists language elements used in the selected programs or projects. The analysis indicates which elements are supported and which are not.

Running analyses

The Code Analyser can quickly analyse single programs, or all programs in one or more projects, or all programs in one or more folders.

Programs that might normally be executed on multiple different platforms can be analysed together. Gather the programs from these other environments, copy them to your workstation and then run the analysis tools from Workbench.

Analysing program compatibility

You can analyse one or more programs to identify which contained language elements are supported in WPS.

To analyse SAS language programs:
1. Select the files to be analysed:
   - Select the required file or files to analyse in the Project Explorer or File Explorer. You can highlight programs in different projects or folders within the particular view.
   - Select one or more projects in the Project Explorer to analyse all contained programs.
   - Select one or more folders in the File Explorer to analyse all contained programs.

2. In the view corresponding to your selection, right-click on the selected items and from the short cut menu click Analyse, and then click Program Compatibility.

When the analysis has finished, a Program Compatibility Report automatically opens in the Workbench.

This report contains details about unsupported language elements used in programs. It does not report on any supported language elements that were used in the programs.

**Analysing language usage**

You can analyse one or more programs to identify supported language elements used in one or more programs.

To analyse SAS language programs:

1. Select the files to be analysed:
• Select the required file or files to analyse in the Project Explorer or File Explorer. You can highlight programs in different projects or folders within the particular view.

• Select one or more projects in the Project Explorer to analyse all contained programs.

• Select one or more folders in the File Explorer to analyse all contained programs.

2. In the view corresponding to your selection, right-click on the selected items and from the short cut menu click Analyse, and then click Language Usage.

When the analysis has finished, a Language Usage Report automatically opens in the Workbench.

This report details the SAS language elements used in the selected programs, and you can explore the detail of this report in the Workbench, or export the content to Microsoft Excel.

**Analysing mainframe programs**

The Code Analyser is a feature of the Workbench and can therefore only be used on platforms on which Workbench is supported. To analyse programs designed to run on a mainframe, copy the required programs from the mainframe to a workstation running the Workbench. When these programs are analysed, the Code Analyser will identify SAS language elements specific to the z/OS platform.

Before analysing programs copied from a mainframe to a workstation:

• We recommended you remove sequence numbers from your jobs.

• Ensure each program file has a file extension of .sas

• Package up the jobs on the mainframe using XMIT.
• Once transferred to the workstation, use XMIT Manager to un-XMIT the jobs for analysis.

Note:

XMIT Manager can only handle PDSs (Partitioned Datasets) and not PDSEs (Extended Partitioned Datasets).

When downloading the XMIT files from mainframe to your workstation, you must specify FB (Fixed Block) with an LRECL (Logical Record Length) of 80 and with no ASCII/EBCIDIC conversion, truncation or CRLF translation.

Viewing or exporting an analysis report

You can view the detail of a Code Analyser report in Workbench, or export the report detail to Microsoft Excel.

When viewing a report in Workbench, you can navigate to more detail, and ultimately to the source program where an issue is located.

• The program compatibility report summary links to a list of programs analysed. From this list you can access a list of problem elements, see where those elements are used within a program, and navigate to the element location within the file.

• The language usage report summary displays the SAS language elements used in the analysed programs. From this list you can find the frequency of SAS language element usage, which programs contain the elements, and navigate to the element location within the file.

Exporting analysis results to Microsoft Excel

The results of a program compatibility report or language usage report can be exported to a Microsoft Excel spreadsheet for either further analysis or to preserve the report information. To export a report:

1. In the report summary page, click Export results to Excel.

2. In the Save as window, enter the required name for the spreadsheet, and browse to the required location before saving it.

Analysis restrictions

Because of the nature of the SAS language, the result of the analysis cannot be guaranteed, and reports should be treated as a guide for further analysis.

The Code Analyser has some limitations:

• The Code Analyser will not report incorrect syntax.

• SAS language elements that are not currently supported in WPS are now shown in the Compatibility Report as unknown.
• The analysis reports do not currently contain information about the use of macro language elements and library engine (data access) elements. Their use is however supported in WPS.

**Import a project**

To import an existing project into the Workbench:

1. Click the **File** menu, click **Import** to open the **Import** wizard.

2. On the **Select** page, expand the tree under the **General** node, select **Existing Projects into Workspace** and click **Next**

3. Select the import method:
   - To import an existing project, click **Select root directory** and either select the project from the list or click **Browse** to navigate to the folder where the project is located.
   - To import an archived project, for example stored as a Zip .zip or Tar .tar file, click **Select archive file**. Select the archive file from the list or click **Browse** to navigate to the folder where the archive file is located.

   If the archive file or folder contains a valid project, the project name is added to the **Projects** list.

4. Click **Finish** to import the selected project.

Use this method to import the samples project supplied with Workbench. Sample projects are available in each supported language, and the project archive file **samples.zip** is located in the doc/ <language> folder in your workbench installation.

**Workbench layout**

The workbench layouts, or **Perspectives**, are designed to support creating, managing, editing and running particular language programs.

**Default WPS perspective**

The default WPS perspective shows Workbench views needed to create and run SAS language programs.

The following is an example of the default WPS perspective. For details on customising this layout, see perspectives ☞ (page 64).
If you change the layout, you can reset the perspective to the default layout. To reset the perspective, click the **Window** menu, click **Open Perspective** and then click **WPS**.

### Online help

The context-sensitive **Help** view automatically displays relevant help items as you select different Workbench views.

This view is not open by default. To add this view to the current perspective click the **Help** menu and then click **Dynamic Help** or press **F1**.

### Help view

The **Help** view displays the content of the WPS documentation. To display the WPS documentation contents, click the **Help** menu and then click **Help Contents**. The **Help** view provides features to help you navigate through the documentation:

- **Show in Contents** – synchronises the table of contents with the help topic you are reading.
- **Bookmark Document** – adds a shortcut to a specific page in the documentation.
• **Search** – search the help for specific keywords and phrases.

## Cheat sheets

The Workbench contains tutorials known as *cheat sheets* designed to help you start using WPS by introducing specific tasks and features.

Cheat sheets can be one of two different types: *simple* or *composite*.

A simple cheat sheet, designed to guide you through a single task, has an introduction to set the scene, followed by is a list of tasks designed to be performed one after another:

- Introduction
- Task A
- Task B
- Task C
- Conclusion

A composite cheat sheet is designed to guide you through a more complex problem. The problem is broken down into smaller manageable groups, each group consisting of an introduction and conclusion:

- **Group One**
  - Introduction
  - Task A
  - Task B
  - Task C
  - Conclusion

- **Group Two**
  - Introduction
  - Task D
  - Task E
  - Task F
  - Conclusion

- **Group Three**
  - Introduction
  - Task G
  - Task H
  - Task I
  - Conclusion

Composite cheat sheets have two panes in the user interface. One shows the groups of tasks, the other shows the tasks in each group.
Open a cheat sheet

Cheat sheets are opened from the help menu in the Workbench.

1. Click the Help menu and then select Cheat Sheets.
2. Select the cheat sheet from the list, and click OK to open.
Close a cheat sheet

You can close the active cheat sheet by selecting the Close on the cheat sheet's tab. The active cheat sheet saves its completion status when it is closed so that you can continue where you left off when you next re-open it.

Working through a cheat sheet

When you open a new cheat sheet, the introduction is expanded so that you can read a brief description about the selected cheat sheet.

In a simple cheat sheet, click Click to Begin at the bottom of the introductory step. The next step is then expanded and highlighted. You should also see action buttons at the bottom of the next step, for example Click to Complete.

In a composite cheat sheet, read the introduction and then click the Go to... link at the bottom of the first sheet. The introduction for the first group is displayed, click the Start working... link to begin. You progress through a group in the same manner as a simple cheat sheet.

In simple cheat sheets or a composite group, when you have finished a particular step, click Click when complete to move to the next step. A check mark ✓ appears in the left margin of each completed step.

Composite cheat sheets have a conclusion, and also the option to review the task, or to progress onto the next group of tasks. Starting the next task will take you to the introduction for the next group.

You can open any step out in a cheat sheet by clicking the title of the section. If you are working through each step in the sheet, click Collapse All Items but Current to collapse all opened steps except the current active step waiting to be completed.

In composite cheat sheets, you can review any previously-completed group by clicking the group in the task group pane. The displayed point in the group is where you left that group, for example if you completed the group tasks, the conclusion is displayed.

A simple cheat sheet is completed when you finish the last step. A composite cheat sheets is complete when all task groups have been finished.

To restart from the first step, open the first step and click Click to Restart. A Composite cheat sheet allows you to reset task groups. Right-click on the task group in the groups pane and click Reset.
WPS server

To run SAS language programs, the Workbench requires a connection to a licensed *WPS server*. The WPS server may be running on the local workstation or on an installation of WPS on a remote machine.

- A WPS server on a local machine – a *local server* – can be accessed through a *local host connection*.
- A WPS server on a remote machine – a *remote server* – can be accessed through a *remote host connection*.

When WPS Workbench is first installed, a single local host connection called *Local* and a server called *Local Server* are created. This server is started by default when the Workbench is started, and terminates when the Workbench is closed.

Further local servers can be created if required or the local server can be deleted or uninstalled. Creating multiple local servers requires no further licensed WPS products and the only restriction on the number of local servers is the local machine resources.

Setting up remote servers gives you access to the processing power of remote server machines from the Workbench on your workstation. Multiple servers can run under a single remote host connection. For more information, see *Connect to a remote WPS server* (page 48).

The list of defined connections and servers is stored in a workspace, and is visible through the *Link explorer*. If you change workspace, you will have different connections and servers. To share server definitions in a work group, or between workspaces, export (see *Export a WPS server definition* (page 51)), and import (see *Import a WPS server definition* (page 52)) server definitions to or from a file.

Configure a local WPS installation

How to configure WPS workbench to remove the WPS server from your workstation.

If you only run SAS language programs on a remote WPS server, you can modify your Workbench installation to remove the local server. This option is only available for Workbench installations on Microsoft Windows.

To remove the WPS server:

1. Open the *Programs and Features* control panel item and select *WPS* in list of installed programs.
2. Click *Change* at the top of the *Programs and Features* window. In the *Change, repair, or remove installation* click *Change*:
3. In the **Custom Setup** window, clear **WPS Local Server** and complete the amended installation.

On a non-Windows platform the WPS server cannot be removed from the Workbench installation. To remove the local server access from Workbench, in the **Link Explorer** view, select the **Local Server** and click **Delete**.
Default WPS server

Set or change the WPS server used by default when running SAS language programs in Workbench.

One of the available server connections defined in Workbench must be identified as the default WPS server to be used when a SAS language program is executed using the Run command.

When Workbench is first installed, the Local Server is the default WPS server; you can select any available server to be the default Workbench server.

To set the default server.

1. Open the Link Explorer view and expand the connection containing the required WPS server.
2. Right-click on the required server and click Set as Default Server on the shortcut menu.

WPS server LOCALE and ENCODING settings

Specifying locale and encoding options for a WPS server.

Any LOCALE option defined in a configuration file is ignored when running SAS language programs from Workbench; the LOCALE must be set as a Workbench start-up option to be effective.

In order to display and save programs and other files that contain characters for your selected LOCALE, you may need to set a General text file encoding (page 24) value for the Workbench.

Set LOCALE for a WPS server

The locale used by WPS is set individually by the particular server. To set the language system option for the locale for a server:

1. In the Link Explorer view, ensure the required server is running.
2. Right-click the server and click Properties on the shortcut menu to display the Properties dialog box.
3. In the properties list, click Startup and then click System Options.
4. On the System Options panel, click Add to display the Startup Option dialog box.
5. In the Name field, type LOCALE, and in the Value field enter the required locale value.
   A list of valid LOCALE values can be found in the WPS Reference for Language Elements.
6. Click OK to save the changes restart the server to apply your changes.
**Set ENCODING for a WPS server**

You may also need to set an appropriate ENCODING value on the server (for example to execute a WPS installation containing non-ASCII characters). As an example, proceed as follows to set UTF-8 on the server:

1. In the **Link Explorer** view, ensure the required server is running.
2. Right-click the server and click **Properties** on the shortcut menu to display the **Properties** dialog box.
3. In the properties list, click **Startup** and then click **System Options**.
4. On the **System Options** panel, click **Add** to display the **Startup Option** dialog box.
5. In the **Name** field, type ENCODING, in the **Value** field type UTF-8 and click **OK**.

A list of valid ENCODING values can be found in the *WPS Reference for Language Elements*.

6. Restart the server when prompted.

**General text file encoding**

To display and save programs and files that contain international characters, you may need to set an appropriate text file encoding.

The text file encoding can be done at either a global – for all Workbench projects and associated files – or project level – for programs contained in the specific project – where a different encoding is required to the inherited global encoding option.

**Set the encoding at a global level**

To set a global encoding value:

1. Click the **Window** menu and then click **Preferences** to display the **Preferences** dialog box.
2. In the preferences list, expand **General** and then click **Workspace**.
3. In the **Workspace** panel, under **Text File Encoding**, click **Other** and select the required value from the list.

    If the required encoding option is not in the drop-down list, enter the encoding name, for example **Shift_Jis** in the **Other** field.

4. Click **OK** to apply your change.

Check the locale is set for your country so that data is handled correctly by the WPS server. The locale is displayed in the bottom right hand corner of Workbench (for example, to **FR_FR** if you are in French territories). If not set, specify the **LOCALE** and **ENCODING** settings. For more information, see WPS server LOCALE and ENCODING settings (page 23).
Setting encoding at a project level

To set a project encoding value:

1. In the **Project Explorer** view, select the required project, right-click and on the shortcut menu click **Properties**.
2. In the **Properties for**... dialog box, in the properties list, click **Resource**.
3. On the left of the **Properties** window, ensure the **Resource** option is selected.
4. In the **Resource** panel, under **Text File Encoding**, click **Other** and select the required value from the list.
   If the required encoding option is not in the drop-down list, enter the encoding name, for example **UTF-8** in the **Other** field.
5. Click **OK** to apply your change.

Licence key

A valid licence key is required to run programs on a WPS server, and each server, whether local or remote, requires a separate licence key.

A licence key is provided in a file ending in **.wpskey** that is separate from the WPS installation file.

Apply a licence key

How to apply a new licence key to your local WPS server.

If you are using a Microsoft Windows operating system, ensure that you have administrator privileges before applying a licence key.

1. Click the **Help** menu and then click **Apply Licence**.
2. In the **Import licence for server Local Server** dialog box, either:
   - Copy and paste the entire contents of your licence file into the window.
   - Click **Import from file**. Find your licence key file and click **Open**.
3. Click **Finish** to apply the licence.

Following installation, you can view the details of the licence. To do so click the **Help** menu and click **View Licence**.
Database connectivity

WPS can be used in conjunction with many different database management systems. This section covers installation of ODBC (Open Database Connectivity) and some of the most commonly-used native clients:

- Oracle, through the Oracle Instant Client.
- DB2, through the IBM Data Server Runtime Client.
- SQL Server, through the SQL Server Native Client.
- MySQL through the MySQL Connector/C.
- Sybase Adaptive Server Enterprise through the Sybase ASE Client

Wherever possible, you should use the native database client to obtain the best support for database options and the SAS language. If you are unable to use a native database client, WPS supported database connectivity using ODBC. For more information about creating an ODBC connection on both Microsoft Windows and Linux systems.

Supported client drivers

The following client connector versions are supported:

<table>
<thead>
<tr>
<th>Engine</th>
<th>Client version</th>
</tr>
</thead>
<tbody>
<tr>
<td>Oracle</td>
<td>Instant Client 12</td>
</tr>
<tr>
<td>DB2</td>
<td>IBM Data Server Runtime Client 10.5</td>
</tr>
<tr>
<td>SQL Server</td>
<td>Microsoft SQL Server 2012 Native Client</td>
</tr>
<tr>
<td>MySQL</td>
<td>Connector/C 6.1</td>
</tr>
<tr>
<td>Sybase ASE</td>
<td>Sybase ASE 15.7</td>
</tr>
</tbody>
</table>

If you use ODBC on Linux, WPS only supports unixODBC version 2.3.2 or later

Connect to Oracle

How to install the Oracle Instant Client on Microsoft Windows.

Before installing the Oracle Instant Client software, ensure that:

- You have installed and licensed WPS.
- You have the requisite administrator privileges to install both WPS and the Oracle Instant Client.
- You download the version of the Oracle Instant Client that matches the version of the Oracle database to which you are connecting.
When installing the Oracle Instant Client, you must match the WPS Workbench installation type:

- The Windows (32-bit) client is required for the 32-bit version of WPS Workbench.
- The Windows (x64) client is required for the 64-bit version of WPS Workbench.

The Oracle Instant Client must be installed on the same PC or server as the WPS server on which your SAS language programs will be run.

To install the Oracle Instant Client:

1. Download the basic Oracle Instant Client from the Instant Client download page of the Oracle website.

2. Once the appropriate installation (.zip) file has been downloaded, create a folder for the instant client on your PC, for example C:\oracle, and unzip the content of the file into that folder:

3. Add the Oracle Instant Client installation directory to the system Path variable, as follows:
   a. In the Control Panel, select the System and Security group. Select System and click Advanced System Settings.
   b. In the Advanced tab, click Environment Variables. Select the Path entry in the System variables list and click Edit…
   c. In the Edit environment variable dialog, click New and enter the installation directory path.
   d. Click OK in the Edit environment variable dialog to save the changes, and close the remaining system and security dialogs.

4. Start WPS Workbench to ensure that the Path environment changes to the path are available.

   You can view the Path variable in WPS Workbench using the following SAS language program:

   ```sas
   DATA _null_
   LENGTH pathname $ 32760;
   pathname = SYSGET('PATH');
   PUT pathname= ;
   RUN;
   ```

   The log output should contain the Oracle Instant Client installation directory.

Once the client has been installed, test the connection using the following:

```sas
LIBNAME DATASRC ORACLE USER=<user_name> password=<password> PATH='<remote-id>/TNS';
PROC DATASETS LIBRARY=DATASRC;
RUN;
```

Replace `<user_name>` and `<password>` with your user name and password for the server. The PATH option contains the server name (specified as `<remote-id>`) and, optionally, a TNS name.

The PROC DATASETS statement returns the names of all tables in the selected database; for databases with large numbers of tables, this program may take some time to run.
Connect to DB2

How to install the IBM Data Server Runtime Client, on Microsoft Windows.

Before installing the IBM Data Server Runtime Client, ensure that:

• You have installed and licensed WPS.
• You have the requisite administrator privileges to install both WPS and the IBM Data Server Runtime Client.

When installing the IBM Data Server Runtime Client, you must match the WPS Workbench installation type:

• The Windows 32-bit AMD and Intel x86 client is required for the 32-bit version of WPS Workbench.
• The Windows AMD64 and Intel EM64T client is required for the 64-bit version of WPS Workbench.

The IBM Data Server Runtime Client, must be installed on the same PC or server as the WPS server on which your SAS language programs will be run.

To install the IBM Data Server Runtime Client:

1. Download the IBM Data Server Runtime Client, from the Download Clients and Drivers page of the IBM website.
2. Once downloaded, locate and run the executable installation file. Follow the instructions in the wizard for the Typical installation type.

   **Note:**
   For ease of future use, you are advised to ensure that the installation folder is on the system path.

3. Set the **DB2CMDEXE** environment variable to point to the **db2cmd.exe** file (typically C:\Program Files\IBM\SQLLIB\BIN\db2cmd.exe), as follows:

   a. In the Control Panel, select the System and Security group. Select System and click Advanced System Settings.
   b. In the Advanced tab, click Environment Variables. In the System variables section, click New…
   c. Create a system variable with a **Variable name** of **DB2CMDEXE**, and a **Variable value** of the IBM Data Server Runtime Client, installation directory, for example C:\Program Files\IBM \SQLLIB\BIN\db2cmd.exe

4. Configure the connection from the IBM Data Server Runtime Client, to the server you will access:

   a. Open a command prompt and run **DB2CMD**.
   b. In the new window, type **DB2** to access the command line processor for the DB2 client.
   c. Create a **node** to reference the remote database, using the following command:

      ```
catalog TCPIP node <node_name> REMOTE <server> SERVER <port_service>
```

   Where:
• `<node_name>` is the local connection name.
• `<server>` is the IP address or name of the server hosting the database.
• `<port_service>` is either the server port number or the database instance name on the server.

d. Create a database instance reference (that you will connect to through the `<node_name>`), using the following command:
   ```bash
catalog database <database_name> AS <alias_name> AT NODE <node_name>
   ```
   Where:
   • `<database_name>` is the instance of the database on the DB2 server.
   • `<alias_name>` is the name you will use in the DB2 client to connect to the database instance.
   • `<node_name>` is the previously-created connection name.

e. Connect to the local connection name (<node_name>) using the following command:
   ```bash
   connect to <node_name> user <user_name> using <password>
   ```
   Where:
   • `<node_name>` is the previously-created connection name.
   • `<user_name>` and `<password>` are your user ID and password for the DB2 server.

If the connection is successful, the database information is displayed and you can close the command line processor for the DB2 client:

```
Database Connection Information
Database server = DB2/LINUX
SQL authorization ID = TEST
Local database alias = TESTDB2
```

Once the client has been installed, test the connection using the following:

```
LIBNAME DATASRC DB2 user=<user_name> password=<password> DSN=TESTDB2;
PROC DATASETS LIBRARY=DATASRC;
RUN;
```

Replace `<user_name>` and `<password>` with your user name and password for the server.

The `PROC DATASETS` statement returns the names of all tables in the selected database; for databases with large numbers of tables, this program may take some time to run.

## Connect to SQL Server

How to install the Microsoft SQL Server Native Client on Microsoft Windows

Before installing the Microsoft SQL Server Native Client, ensure that:

• You have installed and licensed WPS.
• You have the requisite administrator privileges to install both WPS and the Microsoft SQL Server Native Client.

When installing the Microsoft SQL Server Native Client, you must match the WPS Workbench installation type

• The X86 client is required for the 32-bit version of WPS Workbench.
• The X64 client is required for the 64-bit version of WPS Workbench.

The Microsoft SQL Server Native Client must be installed on the same PC or server as the WPS server on which your SAS language programs will be run.

To install the Microsoft SQL Server Native Client:

1. Download the Microsoft SQL Server Native Client installer from the SQL Server Native Client page of the Microsoft website.
2. Once the file has been downloaded, execute the file and follow the onscreen instructions to install the Microsoft SQL Server Native Client.

Once the client has been installed, test the connection using the following:

LIBNAME DATASRC SQLServr user=<user_name> password=<password> server=<remote-id>;
PROC DATASETS LIBRARY=DATASRC;
RUN;

Replace <user_name> and <password> with your user name and password for the <remote-id> server.

The PROC DATASETS statement returns the names of all tables in the selected database; for databases with large numbers of tables, this program may take some time to run.

Connect to MySQL

How to install the MySQL Connector/C client on Microsoft Windows.

Before installing the MySQL Connector/C client software, ensure that:

• You have installed and licensed WPS.
• You have the requisite administrator privileges to install both WPS and the MySQL Connector/C client.

When installing the MySQL Connector/C client, you must match the WPS Workbench installation type:

• The Windows (x86 32-bit) client is required for the 32-bit version of WPS Workbench
• The Windows (x86 64-bit) client is required for the 64-bit version of WPS Workbench.

Note:
The library names for the different versions of the MySQL Connector/C client are identical, so you can only have one version of the client (either 32-bit or 64-bit) registered on the Path system variable.
The MySQL Connector/C client must be installed on the same PC or server as the WPS server on which your SAS language programs will be run.

To install the MySQL Connector/C client

1. Download the MySQL Connector/C client installer (.msi) from the Download Connector/C page of the MySQL website.

2. Once the installation (.msi) file has been downloaded:
   a. Double-click the downloaded file to begin installation (you will need to read and accept the MySQL licence agreement).
   b. Select a Typical installation, and click Install.

3. Add the MySQL Connector/C client installation directory containing libmysql.dll to the system Path variable, as follows:
   a. In the Control Panel, select the System and Security group. Select System and click Advanced System Settings.
   b. In the Advanced tab, click Environment Variables. Select the Path entry in the System variables list and click Edit...
   c. In the Edit environment variable dialog, click New and enter the installation directory path.
   d. Click OK in the Edit environment variable dialog to save the changes, and close the remaining system and security dialogs.

4. Start WPS Workbench to ensure that the Path environment changes are available.

You can view the Path variable in WPS Workbench using the following SAS language program:

```sas
DATA _null_;  
LENGTH pathname $ 32760;  
pathname = SYSGET('PATH');  
PUT pathname= ;  
RUN;
```

The log output should contain the MySQL Connector/C client installation directory.

Once the client has been installed, test the database connectivity by using the following in WPS Workbench:

```
LIBNAME DATASRC MYSQL USER=<user-name> PASSWORD=<password>  
   SERVER=<remote-id> DATABASE=<dbase>;  
PROC DATASETS LIBRARY=DATASRC;  
RUN;
```

In the LIBNAME statement, replace <user-name> and <password> with your user name and password for the <remote-id> server, and replace <dbase> with the name of the MySQL database.

**Note:**
You must supply a DATABASE name in for WPS to successfully connect to the MySQL server.

The PROC DATASETS statement returns the names of all tables in the selected database; for databases with large numbers of tables, this program may take some time to run.
Connect to a database using ODBC

ODBC (Open Database Connectivity) is a database-independent connection option for WPS. You should use ODBC as the connection option where no native connection client exists.

ODBC provides the facility to create a SAS language program that stores data in one RDBMS, and then to modify the database storing the data without the need to modify your program significantly.

The version of ODBC driver you select must match the WPS installation type:

- If you have the 32-bit version of WPS installed, select a 32-bit ODBC driver.
- If you have the 64-bit version of WPS installed, select a 64-bit ODBC driver.

Using ODBC may limit the functionality that would otherwise be available through a native client, for example when using Explicit passthrough commands in PROC SQL. (Explicit passthrough uses SQL as understood by the server to which you are connecting, and passes those statements to the RDBMS verbatim.)

Each ODBC driver requires the creation of a DSN (Data Source Name), and the information required when creating this will vary between databases.

The ODBC Client must be installed, and DSN created on the same PC or server as the WPS server on which your SAS language programs will be run.

The following example creates a DSN for the SQLite ODBC driver:

1. Download the ODBC driver for SQLite from the SQLite ODBC Driver website.
2. Once downloaded, double-click the executable file and follow the on-screen instructions to install the driver.
3. Create an empty file on your PC to hold the database, for example E:\data\mydata.sqlite.
4. Create a DSN for the ODBC driver, as follows.
   a. In the Control Panel, select Administrative tools and then choose either ODBC Data Sources (32-bit) or ODBC Data Sources (64-bit) as appropriate.
   b. On the User DSN tab, click Add... and select SQLite3 ODBC Driver in the Create New Data Source dialog.
   c. In the SQLite3 ODBC DSN Configuration dialog, enter the following information:
      - **Data Source Name** – the name to be referenced by the SAS language programs run in WPS, for example SQLITE.
      - **Database Name** – the file name for the database, for example E:\data\mydata.sqlite.

   Other information is optional, but may provide better data management within the database. For example, to enforce foreign key constraints, select Foreign Keys in the Configuration window. Further details on the options can be found in the SQLiteODBC documentation.
   d. Once all required options have been selected, click OK to create the DSN, and close the ODBC Data Sources dialog.
Once the DSN has been created, test the database connectivity by using the following:

```sql
PROC SQL;
  CONNECT TO ODBC (DATASRC=<dsn-name>);
  EXECUTE (CREATE TABLE test (ID INTEGER, name TEXT)) BY ODBC;
  DISCONNECT FROM ODBC;
QUIT;
```

Replace `<dsn-name>` with the Data Source Name entered in the DSN configuration dialog.

If successful, the WPS log should contain the following information:

```sql
CONNECT TO ODBC (DATASRC=SQLITE);
NOTE: Successfully connected to database ODBC as alias ODBC.
EXECUTE (CREATE TABLE test (ID INTEGER, name TEXT)) BY ODBC;
The statement completed successfully.
NOTE: Successfully passed statement to database ODBC.
```

## Restart the server

Each time that the Workbench is closed, the temporary results associated with the session – the log, all the output results, file references, library references, datasets, and so on – are cleared. If you want to clear the same temporary results prior to the end of the Workbench session, you can restart the WPS server. Restarting the server means that programs will no longer be able to interact with temporary objects created in the previous server session.

Alternatively, you can clear the log or results and keep all the other temporary output.

To restart the server:

1. Click the **File** menu, click **Restart** server and click **Local** (or the name of your remote WPS server). If you are restarting the local server, you can use the **Ctrl + Alt + S** shortcut key.
2. A confirmation dialog box may be displayed. Click **OK** to restart the server. You will not see the confirmation dialog if you have previously selected the **Do not show this confirmation again** option in this dialog box.

### Restarting with Advanced Server Actions

If you have selected **Show advanced server actions** in the WPS Preferences page of the Preferences window, the shortcut menu for the WPS server in the WPS Server Explorer, Output Explorer and Results Explorer views displays alternative restart options:

- **Restart, new WORK** – restart and clear the contents of the WORK library.
- **Restart, keep WORK** – restart and keep the contents of the WORK library.
Views and perspectives

The layout of the items in WPS Workbench is known as a perspective and comprises individual windows that contain one or more views. These views display specific types of information and provide specific functions. Some views also have context-specific toolbars located in the top right of each view.

This section gives an overview of perspectives, and each of the available views and describes the main actions that are carried out within each view.

Project Explorer

The Project Explorer view is used to edit and manage SAS language programs and related files, programs or datasets organised in projects.

Projects can store any kind of local file, and support file system operations, such as running programs. Objects within projects can be managed with Local history (page 40), and they can also be exported to archives or to other folders in the local file system. The Project view cannot be used to manage files stored on a remote file system or files on a local file system that are not part of the project.

The Project Explorer view only displays projects that are in your current workspace. You can create several Projects (page 35) in a workspace, and use each project for a specific task.

Selecting an item in the Project Explorer displays information about that item in the Properties view.

Displaying the view

To display the Project Explorer view:

From the Window menu, click Show View and then click Project Explorer.

Operating system tools

As well as the Workbench's tools, you can use those supplied by your operating system to delete, cut, copy and paste objects into a project. If you do use the operating system tools rather than the Workbench tools, modifications are not preserved in the local history.

You may need to refresh the Project Explorer view to ensure that objects manipulated in this way are displayed correctly. To do this right-click the project and, click Refresh on the shortcut menu.
Projects

A project is a Workbench representation of a folder containing objects such as programs, datasets, files and folders.

WPS uses a project to hold the files and folders that relate to each other. For example, you might have one project containing programs that are still under development and another project for monthly reporting applications. There is no limit to the number of projects you can have open within WPS Workbench.

Each project is defined by a project definition file named .project stored in the root directory of a project. This file can only be viewed in the system file browser and must not be deleted, edited, moved from the project folder or copied into another project.

Only one workspace can be open at a time in Workbench, but you can switch between workspaces as required. The Project Explorer view is used to display and manage the current workspace and projects in the active workspace.

Create a new project

To create a new project:

1. Click the File menu, click New and then click Project to launch the New Project wizard.
2. Expand the General folder, click Project and click Next.
3. Enter the new Project name.
4. To create the new project in a location other than the current workspace folder, clear Use default location and specify a new directory in the Location field.
5. Click Finish to create the new project.

The new project is displayed in the Project Explorer view. If the new project location is not in the workspace folder, the path to the project folder is displayed in the Properties view.

You can also use the Workbench’s copy and paste facility to create a new project based on an existing project.

Create a new folder in a project

To create a new folder:

1. On the File menu, click New and then click Folder to launch the New Folder wizard.
2. The parent for the folder defaults to either the current project or folder selected in the Project Explorer view.
3. Enter a Folder name for the new folder.
4. To change the location of the folder on the file system click Advanced and select one of:

- **Use default location.** The folder is created as a file system folder, in the same location as the parent folder or workspace.

- **Folder is not located in the file system (Virtual Folder).** The folder only exists as a workspace artifact, no folder is created on the file system. You can drag and drop your other project resources into the virtual folder to create links to other files and folders in this new folder, and also add other virtual folders. It is not possible to create physical files and folders within virtual folders.

- **Link to alternate location (Linked Folder).** Creates the folder on the file system in a different location to the parent folder or workspace. Click Browse to select the location on your file system to which to link.

5. Click Finish to create the new folder.

**Move or copy a project file**

To move any folder, file, program, or any other object, between projects, or between folders within the same project:

1. In the **Project Explorer** view, select the object you need to move.

2. Click the **File** menu, and then click **Move**. In the **Move Resources** dialog box, select the new destination project or folder and click **OK** to move the resource.

   If you want to duplicate rather than move the object, click the **Edit** menu and then click **Copy**; select the target folder or project, click the **Edit** menu and then click **Paste**. If you duplicate the object in the same project or folder as the original, you must provide a different name for the copied object.

To return the object to its original location, click the **Edit** menu and then click either **Undo Move Resource** if the object was moved, or **Undo Copy Resource** if the object was duplicated.

**Linking the active file to the Project Explorer**

If you have several files from different projects open in the **Editor** view, you can configure the **Project Explorer** view to highlight the program in the project or folder each time that you switch the focus to that program in the **Editor** view.

To link the **Project Explorer** view and the **Editor** view, in the **Project Explorer** view click **Link with Editor**.

**Delete a file from a project**

To delete an object from a project:
1. In the **Project Explorer** view, select the required object to delete.
2. Click the **Edit** menu, and then click **Delete**. In the **Delete Resources** dialog box, click **OK**.

To return the object to its original location, click the **Edit** menu and click either **Undo Delete Resource**.

### Rename a project or project file

To rename a project, or an object in a project:

1. In the **Project Explorer** view, select the required object or project.
2. Click the **File** menu and then click **Rename**.
3. Enter the **New name** in the **Rename Resource** dialog box and click **OK**.

### Copy a project

You can use the Workbench’s **Copy** and **Paste** facility to create a new project based on an existing project.

1. In the **Project Explorer** view, select the required project.
2. Click the **Edit** menu, and then click **Copy**.
3. Click the **Edit** menu, click **Paste** and in the **Copy Project** dialog box, enter a new **Project name**.

   If you want to copy the project to a location other than the current workspace, clear **Use default location** and enter an alternate **Location** for the new project.

4. Click **OK** to create the project.

### Import files or archives

You can import files from either an archive file (such as a zip file) or from the file system into an existing project.

To import files:

1. Click the **File** menu and then click **Import** to open the **Import** wizard.
2. Expand the tree under the **General** node and select one of the following options:
   
   - **File System** – to import files and folders not archived in a single file.
   - **Archive File** – to import files and folders that are archived in one file (for example, a zip, or tar.gz).

3. Click **Next** and click **Browse** to select either the archive file or directory.
4. You will see a list of the files and folders that are available to import. Ensure that all the objects that you want to import are selected.

Do not select the parent folder of the files to import; if you do, your imported files are added to a subfolder in your project.

Note:
Do not import a project definition file (.project); if you do the imported file will overwrite the project definition file in the existing project.

5. Click Browse and specify the Into folder – the target folder for the imported files.
6. Click Finish to import the selected files.

Close and reopen a project

You can close or open a project to control the number of available projects in a workspace.

To close a project:
1. In the Project Explorer, right-click an open project and click Close Project on the shortcut menu.

Closing a project collapses the tree under project in the Project Explorer view and closes any programs or other files that were open in the Workbench Editor view.

If you want to open or reopen a closed project, in the Project Explorer, right-click a closed project ( ) and click Open Project on the shortcut menu.

Export a project

To make a copy or backup of a project and all the files and folders contained within it:
1. In the Project Explorer view, select the project to export.
2. Click the File menu and then click Export to display the Export wizard.
3. On the Select page, expand the General node and select
   - Archive File to create zip file in the export location.
   - File System to makes a copy of your project folder and its contents.
4. Click Next and select the folders and files to export from the selected project
5. If you are exporting to an archive, enter the path for file, including filename in To archive file. If you are exporting to the file system, enter the folder path in To directory.
6. Click Finish to export the selected folders and files.
Delete a project

To delete a project:

1. In the **Project Explorer** view, select the required project to delete.
2. Click the **Edit** menu and click **Delete**.
3. In the **Delete Resources** dialog box, choose whether to delete the reference to the project in the current workspace, or delete the reference and the folder contents on disk:
   - To remove the workspace reference to the project without deleting the project folder and contents, clear **Delete project contents on disk (cannot be undone)**.
   - To remove the workspace reference and folder contents from the disk, select **Delete project contents on disk (cannot be undone)**.
4. Click **OK**.

Comparing and merging multiple files

You can carry out either two-way or three-way comparisons between different versions of a file.

Three-way comparisons show the differences between three different versions of a file, for example the differences between the resource in the Workbench, the version of the resource that is committed in a branch, and the **common ancestor** on which the two conflicting versions are based. If a common ancestor cannot be determined, for example because a resource with the same name and path was created and committed by two different developers, the comparison becomes a two-way comparison.

1. In the **Project Explorer**, highlight the files that you want to compare. You can select up to three different files.
2. Right-click, and on the shortcut menu, click **Compare With** and then click **Each Other**.
   - In a two-way comparison, the **Text Compare** window displays the differences (marked in grey) between the two files.
   - In a three-way comparison, select the **common ancestor** – the file against which comparisons will be made. The **Text Compare** window displays the two file versions. To display the common ancestor at the same time, click **Show Ancestor Pane**.
3. Make the required changes to the files

You can navigate through the files using the text compare toolbar:

- Click **Next Difference** to show the first difference between the files after the cursor location or highlighted text.
- Click **Previous Difference** to show the first difference between the files before the cursor location or highlighted text.
- Click **Next Change** to show the first change between file versions after the cursor location or highlighted text.
• Click **Previous Change** to show the first difference between file versions before the cursor location or highlighted text.

You can merge changes from one file to the other using the text compare toolbar:

• Click **Copy Current Change from Right to Left** to overwrite the highlighted text in the left file with the highlighted text in the right file.

• Click **Copy All from Right to Left** to replace the content of the left file with the content of the right file.

• Click **Copy Current Change from Left to Right** to overwrite the highlighted text in the right file with the highlighted text in the left file.

• Click **Copy All from Left to Right** to replace the content of the right file with the content of the left file.

4. Once you have made your changes, click the **File** menu and then click **Save**.

5. Click the **File** menu and then click **Close** to close the **Text Compare** window.

---

**Local history**

The Workbench maintains a local history of modifications to programs or other project files changed in the **Project Explorer** view.

Each time you save a project file in the Workbench, a snapshot of the current contents of the file is added to the Workbench's local history. This history provides the ability to take any of your current programs and compare or replace them with local history.

**History of Deletions**

Each time you delete a program or file, the edit history of the item being deleted is added to the local history of the containing project or folder. This enables you to restore state from local history, or to select which particular state from the item's history to restore. See **Restore from local history** (page 42) and **Replace from local history** (page 41) for more information.

**Local History Preferences**

Local history preferences allow you to control how long to keep the local history, how many entries to keep in the history, and the maximum file size that can be recorded. See **Local history preferences** (page 42) for more information.

**Compare with local history**

To compare a current saved project file with a previous version:
1. In the **Project Explorer** view, select the required file, right-click, click **Compare With** and then click **Local History** on the shortcut menu.

   A **History** window opens listing program revisions with revision times.

2. Double-click the revision with which you want to compare the current version of the file.

   The **Text Compare** window opens showing the differences (marked in grey) between the two versions. The current version is shown on the left, with the local history version on the right.

3. Make the required changes to the files

   You can navigate through the files using the text compare toolbar:

   - Click **Next Difference** to show the first difference between the files *after* the cursor location or highlighted text.
   - Click **Previous Difference** to show the first difference between the files *before* the cursor location or highlighted text.
   - Click **Next Change** to show the first change between file versions *after* the cursor location or highlighted text.
   - Click **Previous Change** to show the first difference between file versions *before* the cursor location or highlighted text.

   You can merge changes from one file to the other using the text compare toolbar:

   - Click **Copy Current Change from Right to Left** to overwrite the highlighted text in the left file with the highlighted text in the right file.
   - Click **Copy All from Right to Left** to replace the content of the left file with the content of the right file.

4. Once you have made your changes, click the **File** menu and then click **Save**.

5. Click the **File** menu and then click **Close** to close the **Text Compare** window.

---

### Replace from local history

**How to revert a program in a project back to a previous saved version**

You can either replace the current version with the previous version or select a version from the local history.

1. To replace the current version with the previous version, in the **Project Explorer** right-click the required file and, on the shortcut menu, click **Replace With** and then click **Previous from Local History**

2. To replace the current version with a version from the local history:

   a. In the **Project Explorer** right-click the required file and, on the shortcut menu, click **Replace With** and then click **Local History**
b. In the Compare dialog, Double-click a revision to review and select the required version. Click Replace to use the selected version.

**Restore from local history**

Recovering a project file that has been deleted in the Project Explorer view.

To restore a project file:

1. In the Project Explorer view, right-click either the project or a contained folder and on the shortcut menu click Restore from Local History.
2. In the Restore from Local History, select the files to restore:
   1. Click the check box next to the project file name To restore the last version of that file.
   2. If a selected file has a saved local history, select the file name and choose the required version of the file in the Select an edition of a file panel.
3. Click Restore to recover the selected files and close the Restore from Local History dialog box.

**Local history preferences**

By default, the Workbench keeps seven days of local history for each individual project file, with a maximum of fifty versions for each file. There is also a default of 1 MB of storage allocated for each program's local history.

The above settings can be changed as follows:

1. Select Window ➤ Preferences… ➤ General ➤ Workspace ➤ Local History.

   The Local History dialog is displayed.

2. Set any of the following as required:

   - **Days to Keep Files** - The number of days that you want to keep records for any one project file. For example, if you type 20, then a history of saved versions from the last twenty days will be kept. The default value is 7 days.
   - **Maximum Entries per File** - The number of versions to keep for any one project file. If this number is exceeded, the oldest changes are discarded to make room for the new changes. The default is 50 versions per file.
   - **Maximum File Size (MB)** - The maximum file size (in MB) for a project file's local history. If this size if exceeded, then no more local history is kept for the file. The default size is 1MB.

**Note:**

The Days to Keep Files and Maximum Entries per File are only applied when the local history is compacted on server shutdown.
Switching to a different workspace

How to switch to a different workspace, to use a different group of projects:

1. Click the File menu, click Switch Workspace and click Other.
2. In the Workspace Launcher, select the required Workspace or expand the Recent Workspaces list and select the required workspace if it appears in the list.
3. Click OK to restart Workbench displaying the selected workspace.

File Explorer

The File Explorer view is used to edit and manage SAS language programs and related files, programs or datasets on your file system.

The File Explorer view can be used to manage SAS language programs and associated files on remote and local file systems. Because the File Explorer view does not manage content through projects, you cannot use the local history, not use Workbench functionality to import or export projects or archives.

The File Explorer view enables access to all files that are available on your local file system, and on any connected remote hosts. The view also displays the following object types:

- **Connections**: The root node that represents a connection to a host machine. This can be either local or remote.
- **Shortcuts**: A directory on a file system selected for management via the File Explorer view.
- **Symbolic linked file**: A file that points to another file in the host file system via a symbolic link.
- **Symbolic linked directory**: A file that points to another directory in the host file system via a symbolic link.

Selecting an item (other than a connection) in the File Explorer displays information about that item in the Properties view.

Displaying the view

To display the File Explorer view:

From the Window menu, click Show View and then click File Explorer.

Connections and shortcuts

It is only possible to view files on remote systems when you have an open host connection. The host connection is opened from the Link Explorer view, or when starting WPS servers in the WPS Server Explorer view.
Each host connection can have several directory shortcuts, each providing access to the files and folders on the associated file system.

To create a new directory shortcut, in the File Explorer view, right-click on the required folder, click New and click Directory Shortcut in the shortcut menu and enter a Directory Name in the Directory Shortcut dialog box.

Working with files and folders

It is possible to perform the following operations on files and folders within the File Explorer:

• Create a new directory shortcut, directory or file.
• Selected files and directories to be moved, copied or deleted.
• Run a program on a selected WPS server.
• Rename a selected file or directory.
• Analyse the contents of programs, and folders containing programs (see Code Analyser (page 12) for more information).

File explorer preferences

To display hidden files and folders in the File Explorer view, in the Preferences dialog box, expand the WPS group, select File Explorer and in the File Explorer panel select Show hidden files and folders.

Managing files in the File Explorer

The File Explorer view can be used to manipulate the various objects in the available local and remote file systems.

When you open files from the File Explorer view, the file is displayed in the most appropriate Editor view:

• Program files (those with .wps and .sas file extensions) are opened in the SAS editor.
• Text files (.txt) are opened in the Text Editor.
• XML files (.xml) are opened in the Text Editor.
• HTML files (.html) are opened in Workbench where possible (this is platform-dependent).

On some operating systems, the Workbench attempts to open the application associated with the file, for example PDF files, even if the file cannot be opened in Workbench itself.

Create a new folder in a file system

Folders can be created wherever you have appropriate operating system privileges for the particular local or remote host.
1. Click the **Window** menu, click **Show View** and then click **File Explorer** to display the **File Explorer** view.

2. In the **File Explorer** view, right-click the required parent directory shortcut or Folder, click **New** and click **Folder** on the shortcut menu.

3. Enter a new **Folder name** and click **Finish**.

Create a new file or program in a file system

To create a new file in an existing file system, proceed as follows:

1. In the **File Explorer** view, right-click the Directory Shortcut or Folder, click **New** and then click **File** on the shortcut menu.

   If you are creating a new SAS language program, click **New** and then click **Program** on the shortcut menu.

2. In the dialog box, enter a **Filename**, including file extension, and click **Finish**.

   If you are creating a new SAS language program, the **Filename** has a default extension of .sas, you can change this to .wps if you prefer.

Moving a file in a file system

You can move files to other folders in your local and remote connections. To move objects in the **File Explorer** view:

1. Click the **Window** menu, click **Show View** and then click **File Explorer** to display the view.

2. In the **File Explorer** view, right-click the required object to move and click **Cut** on the shortcut menu.

3. Right-click the target Shortcut Directory or Folder to which you want to move the object and click **Paste** on the shortcut menu.

   Alternatively, you can select the object you want to move and drag the object to the required Shortcut Directory or Folder.

Renaming an object in a file system

To rename a file system object:

1. In the **File Explorer** view, right-click the required object to rename and click **Rename** on the shortcut menu.

2. In the **Rename File**, enter a new name for the file and click **OK**.

   You may need to refresh the connection in the **Link Explorer** view to see the change.
Deleting an object from a file system

To delete an object from a file system, proceed as follows:

1. In the File Explorer view, Right-click on the required object to delete and click Delete on the shortcut menu.
2. In the Confirm Delete dialog box, click OK to confirm deletion.

Once you confirm the deletion of the object from the file system, the operation cannot be undone.

Link Explorer

The Link Explorer view allows you to manage host connections, and any WPS servers on those connections.

The Link Explorer view is the key view if you are using WPS Link – the collective term for the technology used to provide a client/server architecture.

Using the Workbench on your local PC, you can connect to a remote machine on which the WPS server is installed to run SAS language programs. The output from the remote server can be viewed and manipulated in Workbench, in the same manner as a locally-executed program.

Displaying the view

To display the Link Explorer view
From the Window menu, click Show View and then click Link Explorer.

Objects displayed

There are two node types visible in this view:

1. A Connection node – represents a connection to a host machine. The connection can either be a local connection or a connection to a remote machine and contain one or more WPS server nodes.
2. A Server node – represents the WPS server installation where you may run your SAS language programs.

Managing the connections and servers

From this view you can:

• Open or close a local or remote host connection.
• Stop, start or restart a WPS server in the connection
• Export a host connection (see Export a host connection definition (page 50)).
• Define a new WPS server (see Define a new WPS server (page 51)).
• Import or export a WPS server definition (see Import a WPS server definition (page 52) or Export a WPS server definition (page 51)).

A WPS server can be moved or copied to a different host connection. A drag and drop operation moves the server from its current host connection to the target host connection. Press and hold the Ctrl key at the same time to copy the WPS server to the new host connection.

Commands (top right corner of the view)

The view contains the following commands

• Collapse All – collapse the view to show just the root nodes.
• Create a new remote host connection – add a new remote connection.
• Import a host connection definition – import a connection definition file.

Local host connection properties

The local host is created during workbench installation, and the only properties available for a local host connection are directory shortcuts.

To access local host connection properties, in the Link Explorer view, right-click on the Local host connection and click Properties in the shortcut menu.

A directory shortcut is a shortcut to a directory on the local file system. The local shortcuts that are created by default differ in accordance with the operating system on which you are running the Workbench:

• On Microsoft Windows operating systems, there will be Home and Workspace shortcuts, and also a shortcut for each available local drive. For example, if you have drives C: \ and D: \ on your computer, there will be four shortcuts by default.
• On all other operating systems, only the Home (~) and Root (/) shortcuts are created by default.

Create a new shortcut

To create a new directory shortcut:

1. In the Link Explorer view, right-click on the Local host connection and click Properties in the shortcut menu.
2. Click Add to display the Directory Shortcut dialog box.
3. In Directory Name enter the displayed shortcut name, and in Directory Path the full path of the target directory. Click OK to save the changes.
Connect to a remote WPS server

How to create a link from Workbench to a WPS server on a remote machine.

The WPS server must exist before a connection can be made from Workbench. The remote server requires an SSH server and a licensed copy of the WPS server. For information about setting up a remote server for WPS, see the WPS Link user guide and reference.

Client/server installation summary

Before connecting to a remote server, you require the hostname for the remote server, the user name and password log on credentials, and the full WPS server installation path on the remote server.

To create a connection to a remote server:

1. Create a connection to the remote host. See Create a new remote host connection (page 48).
2. Add a WPS server to this remote host. See Define a new WPS server (page 51).

Create a new remote host connection

Before creating a new connection, you will need

- SSH access to the server machine that has a licensed WPS server installation.
- The installation directory path for the WPS server installation.

You may need to contact the administrator to obtain this information, and to ensure that you have access. For more details about SSH authentication, see the WPS Link user guide and reference.

To create a new remote host connection:

1. Click the WPS menu, click Link and then click New Remote Host Connection. The New Server Connection dialog is displayed.
2. Select New SSH Connection (3.2 and later -- UNIX, MacOS, Windows).
3. Click Next and complete the New Remote Host Connection (3.2 and later) dialog box:
   a. In Hostname, enter the name or IP address of the remote server machine.
   b. Unless modified by your system administrator, the default Port value (22) should be left unchanged.
   c. In Connection name enter a unique name to be displayed in Workbench for this connection.
   d. In User name, enter your user ID on the remote host.

Click the required check box:
<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable compression</td>
<td>Controls whether or not data sent between the Workbench and the remote connection is compressed.</td>
</tr>
<tr>
<td>Verify Hostname</td>
<td>Confirms whether the host you have specified in the Hostname entry exists.</td>
</tr>
<tr>
<td>Open the connection now</td>
<td>Whether the connection is automatically opened immediately.</td>
</tr>
<tr>
<td>Open the connection automatically on</td>
<td>Controls whether the connection is automatically opened when the Workbench is started.</td>
</tr>
<tr>
<td>Workbench startup</td>
<td></td>
</tr>
</tbody>
</table>

4. Click **Next** to define the connection directory shortcuts:

1. Click **Add** to display the **Directory Shortcut** dialog box.
2. In **Directory Name** enter the displayed shortcut name, and in **Directory Path** the full path of the target directory. Click **OK** to save the changes.

Enter the displayed shortcut name in **Directory Name**, and the full path in **Directory Path** and click **OK**.

5. Click **Finish** to save the changes.

If you have not previously validated the authenticity of the remote host, an **SSH2 Message** dialog box is displayed:

If the identity of the host is correct, click **Yes**.

6. In the **Password Required** dialog enter your **password** for the remote machine and click **OK**.

The **Link Explorer** view contains an entry for the new connection, with a server on which you can run SAS language programs.
Advanced connection options

Controlling the environment variables available to a remote WPS server.

By default the WPS server process inherits the interactive shell environment for the user under whose ID the server is being started. The default environment may not include everything required by the WPS server, for example database client shared libraries may not be defined for the server.

On Unix/Linux systems, this might require that any special environment variables for the WPS server are added to the `LD_LIBRARY_PATH`; or the `/etc/profile` or `~/.profile` modified so that database client shared libraries can be loaded by the WPS Server.

An alternative on Unix/Linux is to place a `wpsenv.sh` file in the WPS installation directory, or in your home directory. This file is automatically run before the server is launched.

On Windows, any special environment variables for the WPS server should be configured through the Control Panel, as either system or user environment variables.

---

**Note:**

All processes running as the user will see the created variables, and there is no way to specify that they should only be visible to the WPS process.

---

Export a host connection definition

A host connection definition can be exported from Workbench to enable sharing in a workgroup or to copy connection definitions between workspaces.

To export host connection definitions:

1. In the Link Explorer view, select the connection for which definitions will be exported.
2. Right-click the connection and click Export Host Connection in the shortcut menu.
3. In the Export to File dialog box, navigate to the save location, enter a File name and click Save. The exported file `.cdx` contains the connection definition in XML format.

The host connection definition is saved to the selected file, which can be shared in the workgroup.

You can select multiple connections in the Link Explorer view and export them all to the same definition file to share more than one connection definition.

See Import a host connection definition (page 51) for how to import the connection definitions into a workspace.
### Import a host connection definition

A host connection definition can be imported into Workbench to use consistent host definitions in a workgroup or between workspaces.

This task assumes that you have previously exported some connection definitions to a file, or have been provided with an export file created by someone else in your work group.

1. Click the **WPS** menu, click **Link**, and then click **Import Host Connection Definition**.
2. In the **Import Remote Host Connection** dialog box, select the required connection definition file (.cdx) and click **Open**.

The host connection definition is imported from the selected file.

If there are any name clashes, the imported connection definition is automatically renamed so that it has a unique name within your list of connections.

### Define a new WPS server

Workbench allows you to have multiple WPS servers defined on a local or remote host connection.

To define a new server:

1. In the **WPS** menu, click **Link**, click **New WPS Server** and then either click **Local** or the connection name of the remote server.
2. In **New WPS Server** dialog box, enter a unique display name in **Server name**.
   
   If you are defining a new remote WPS server, enter the path to the WPS executable on the remote server in **Base WPS install directory**.
3. Click **Start the server now** and **Start the server automatically on connection startup** to ensure the WPS server can be used whenever Workbench is started.
4. Click **Finish** save the changes.

The **Link Explorer** view contains an entry for the new WPS server. If required, you can configure the startup options for the new server, see *WPS server properties* (page 53).

### Export a WPS server definition

A WPS server definition can be exported from Workbench to enable sharing in a workgroup or to copy connection definitions between workspaces.

To export a WPS Server definition:

1. In the **Link Explorer** view, select the server for which the definition will be exported.
2. Right-click the server and click **Export WPS Server Definition** in the shortcut menu.

3. In the **Export to File** dialog box, navigate to the save location, enter a **File name** and click **Save**. The exported file `.sdx` contains the connection definition in XML format.

The WPS server definitions will be saved to the selected file, which can be shared in the workgroup.

You can select multiple servers in the **Link Explorer** view and export them all to the same definition file to share more than one connection definition.

See *Import a WPS server definition* (page 52) for how to import the server definitions into a workspace.

### Import a WPS server definition

A WPS server definition can be imported into Workbench to use consistent definitions in a workgroup or between workspaces.

A WPS server definition can only be imported into a host connection. If you need to create a host definition, see *Create a new remote host connection* (page 48).

To import a WPS server definition

1. Click the **WPS** menu, click **Link**, and then click **Import WPS Server Definition**. Launch the **Import from File** dialog by doing one of the following:

2. In the **Import from File** dialog box, select the required server definition file (.sdx) and click **Open**.

The WPS server definitions are imported from the selected file.

If there are any name clashes, the imported server definition is automatically renamed so that it has a unique name within your list of WPS servers.

### WPS Server Explorer

The **WPS Server Explorer** view is used to display all Filerefs, libraries, catalogs and datasets generated from running a SAS language program on a WPS server.

While the WPS server is running, the Filerefs and library contents generated from previous SAS language programs are preserved. To remove these items, you need to restart the server.

#### Displaying the view

To display **WPS Server Explorer** view

From the **Window** menu, click **Show View** and then click **WPS Server Explorer**.
Objects displayed

The view contains a WPS Server node that represents the WPS server where your SAS language program has run. Under this node:

- **Libraries** – a parent node for individual library items.
  
  The libraries node contains a library node called Work. This is the default temporary library used if one is not specified in a program.

- **Library** – a collection of catalogs and datasets.
  
  If you use a LIBNAME statement in a SAS language program to specify your own library name, then you will see a library node with the specified name also listed in the view.

- **Catalog** – a collection of user-defined items such as formats and informats.

- **Dataset** – a data file containing numeric and/or character fields.

- **Dataset View** – a dataset created by invoking a view in the source data.

- **Numeric Dataset Field** – a dataset field that contains numeric values.

- **Character Dataset Field** – a dataset field that contains character values.

- **Filerefs** – The parent node for Fileref items.

- **Fileref** – an individual reference to a file.
  
  Filerefs are normally generated automatically, but you can create a Fileref using the FILENAME statement, for example:

  ```
  filename shops 'c:\Users\fred\Desktop\4.1-Shops.xls';
  ```

  The link between a Fileref and its associated external file lasts for the duration of the current WPS session, or until you change it or discontinue it. To keep a Fileref from session to session, then save the FILENAME statement in the relevant program(s).

If you select an item in the **WPS Server Explorer** view, information about that item displayed in the **Properties** view.

WPS server properties

The following properties and information are available for a WPS server:

**Code Submission**

Sets the server working directory to the directory from which the program is opened.

**Environment**

A read-only list describing the server's environment (working directory, process ID and environment variables). This information is only available when the server is running.
Macro Variables
A list of the automatic and global macro variables used by the server, and the associated values. This information is only available when the server is running. Existing variables cannot be modified, but new variables can be created.

Startup
The main page has an option called Start the server automatically on connection startup. Ensure that this is selected to automatically start the server whenever the associated connection is launched. The Initial current directory for server process option specifies the working directory for the server, determining where the output is generated. If you have INCLUDE statements in your program using relative paths, it is important that you start the server in the correct directory to allow those INCLUDE statements to find the files.

The Startup page contains:

System Options
Enables you to specify any WPS options to be processed by the server on startup. Click Add... to specify the name and value of the option. You can then use Edit... and Remove to modify and delete any previously-created options and values.

Environment Variables
For a local WPS server only
Used to specify any environment variables to be set before the server is started. Click New..., to specify the name and value of the variable. You can use Edit... and Remove to modify and delete previously-created environment variables.

System Options
When the WPS server is running, provides a read-only list of system options and their values currently set on the server. This is the same information as would by provided via the OPTIONS procedure.

WPS Licence Information
Displays the licence information for the server. The information cannot be modified and is only available when the server is running.

WPS Software Information
Displays details about the WPS software. The information cannot be modified and is only available when the server is running.

Properties
The Properties view displays the properties of a selected object.

Select an object in one of the following views to show the object details in the Properties view:

• File Explorer view
• Link Explorer view
• Project Explorer view
• Search view
• WPS Server Explorer view

Displaying the view
To display the Properties view
From the Window menu, click Show View and then click Properties.

Editor

When you open any type of file in the Workbench, the file is opened as a tab in the Editor view.
The Editor view is the main interactive view when creating or editing SAS language programs. The view is also used to display output such as result datasets or log information.
Datasets opened from the WPS Server Explorer view, and files opened from the Project Explorer view or File Explorer view can be edited. Logs and output files can be viewed but not edited.
The Editor view can be split to view or modify two or more files together. To split the view, from the Window menu, click Editor and then click Toggle Split Editor (Vertical). The editor can also be split horizontally by using Toggle Split Editor (Horizontal), and you can open another copy of the current file by using the Clone option.

Bookmarks

The Bookmarks view lists the bookmarks added to any program or file in a project.
You can add bookmarks on any line in any program or file you can open from the Project Explorer view, and edit with the Editor view.
The Bookmarks view lists bookmarks for all programs in all open projects. Bookmarks cannot be created for programs not managed through the Project view.
To open a file at the bookmark, double-click the bookmark in the Bookmarks view. The file is opened in the Editor view, with the bookmarked line highlighted, or at the first line in the file if the entire file was bookmarked.

Displaying the view
To display the Bookmarks view:
From the **Window** menu, click **Show View** and then click **Bookmarks**.

### Bookmark anchors

A bookmark is an anchor that you can specify to navigate back to that point at any time.

There is no limit to the number of bookmarks that you can create either against a particular line in the program, or a program file as a whole.

You can list, and navigate between, all your bookmarks using the **Bookmarks** view. If you export a project containing bookmarks, the individual bookmarks are not exported with it.

### Add a bookmark

To add a new bookmark on a particular line in a program:

1. Open the program or file in the **Editor** view.
2. Right-click in the grey border to the left of the required line and click **Add Bookmark** on the shortcut menu:
3. Enter a bookmark name in the **Add Bookmark** dialog box and click **OK**.

   A bookmark tag (▍) is displayed in the border, and a corresponding entry made in the **Bookmarks** view.

You can also add a bookmark to a whole file: select the file in the **Project Explorer** view, click **Edit** menu and then click **Add Bookmark**.

### Delete a bookmark

To delete a bookmark:

1. Click the **Window** menu, click **Show View** and then click **Bookmarks**.
2. In the **Bookmarks** view, right-click the bookmark's description and click **Delete** on the shortcut menu.
Tasks

The **Tasks** view lists any tasks added to any program or file in a project.

You can add tasks on any line in any program or file you can open from the **Project Explorer** view, and edit with the **Editor** view.

The **Tasks** view lists tasks associated with all programs in all open projects. Tasks cannot be created for programs not managed through the **Project** view.

You can use the **Tasks** view to change the priority levels, modify descriptions, and mark them as completed or leave them uncompleted.

You can add **Task markers** (page 57) (reminders) against any line in a program that has been opened from the **Project Explorer** (page 34), and associate each of them with notes and a priority level. To list, update and navigate between any tasks you have added, you need to use the **Tasks** view.

To open a file associated with a task, double-click the task in the **Tasks** view. The file is opened in the **Editor** view, with the relevant line highlighted.

Displaying the view

To display the **Tasks** view:

From the **Window** menu, click **Show View** and then click **Tasks**.

Task markers

A task marker represents a reminder about a work item.

Task markers can only be added to programs in a project. You can add a task and associate a short description and a priority level (one of High, Normal or Low) against any line in a program. You can list and navigate between all your tasks in the **Tasks** view.

There is no limit to the number of task markers that you can add to a program. However, if you export a project, the individual tasks are not exported with it.

Add a task

To add a new task marker on a particular line in a program:

1. Open the program or file in the **Editor** view.
2. Right-click in the grey border to the left of the required line and click **Add Task** on the shortcut menu.
3. In the **Properties** dialog, enter a **Description** and select the **Priority** for the task.

4. Click **OK**, to save the task

A task marker (.idea) is displayed in the border, and a corresponding entry in the **Tasks** view.

---

**Delete a task**

To delete a task:

1. Click the **Window** menu, click **Show View** and then click **Tasks**.
2. Right-click on the task’s description, and click **Delete** on the shortcut menu.

---

**Outline**

The **Outline** view displays structural elements for a file that can be used to locate the line associated with the element.

Opening or giving focus to a program, log, listing or HTML result file, automatically refreshes the **Outline** view to display the structural elements that are relevant to the active item.

---

**Displaying the view**

To display the **Outline** view:

From the **Window** menu, click **Show View** and then click **Outline**.

---

**Displayed structural elements**

Viewing programs displays the following structural elements in the **Outline** view:

- 🌐 Global statement
- 💡 DATA step
- 🕵️‍♂️ Procedure
- 👨‍💻 Macro

Viewing the log file displays the following structural elements in the **Outline** view:

- 📊 An individual log entry.
- 🚨 Error
- 🚨 Warning

Viewing the output results from program execution displays the following structural elements in the **Outline** view:
• Results parent node
• HTML tabular output
• Listing tabular output

You can control which structural elements are displayed in the Outline view using the toolbar at the top of the view panel.

Output Explorer

The Output Explorer view displays the output files generated from running a SAS language program. Output items are associated with the server on which they were generated, and may be one of the following types:

• Listing output
• HTML output
• PDF output

Log output is always shown for each server.

Displaying the view

To display the Output Explorer view:

From the Window menu, click Show View and then click Output Explorer.

View output

Double-click on one of the output nodes to open the output type in its associated editor. For output types other than log output the individual result elements are listed in the Results Explorer view when the output is opened.

Results Explorer

The Results Explorer view displays the results from every SAS language program that has been executed.

The view contains hierarchical links to the results, grouped by server, since the last time that the server was started.

Displaying the view

To display the Results Explorer view:
From the **Window** menu, click **Show View** and then click **Results Explorer**.

**Output**

Once a program has been executed, an entry appears under the relevant server for every procedure that created output. For example **PROC PRINT** will produce an entry named *The PRINT Procedure*. Expand this link to find each type of output that has been generated.

**Console**

The **Console** view displays all system standard output and system standard error messages produced by a WPS server.

The **Console** view is automatically opened when a system error is reported.

**Displaying the view**

To display the **Console** view:

From the **Window** menu, click **Show View** and then click **Console**.

**Search**

The **Search** view displays the results of searches carried out using the **Search** dialog box.

When you click an item in the **Results** view, the file is opened in the **Editor** view, with the relevant line highlighted.

To open the **Search** dialog box, click the **Search** menu and then click **Search**. The **Search** view opens automatically to display the results.

**WPS Hub**

WPS Hub is an Enterprise Management Tool that enables the centralised management of access to data sources.

WPS Hub uses authentication domains to store user credentials for database server access, which can then be referenced in a program, removing the need for user credentials to be stored as part of the program.
A WPS Hub authentication domain is a central definition of access credentials for a database. An authentication domain contains one or more credentials, each of which defines a username and password that can be used to access a database server. Each credential is associated with a WPS Hub user or group, and programs you create can use the authentication domain instead of hard-coding the access credentials.

Using WPS Hub

WPS Hub provides access to centrally-managed library references and authorisation domain credentials to connect to database servers.

Before connecting to WPS Hub, you require access credentials and remote host details. These details are provided by your WPS Hub administrator.

1. On the WPS Hub menu click Log in.
2. In the Hub Login dialog box complete the required information:
   a. Select the required Protocol, either HTTP or HTTPS.
   b. Enter the Host name provided by your WPS Hub administrator.
   c. Enter the Port for WPS Hub. By default, Hub configured for HTTPS will use port 8443, and when configured for HTTP, port 8181.
   d. Enter the WPS Hub Username provided by your WPS Hub administrator.
   e. Enter the WPS Hub Password provided by your WPS Hub administrator.
3. Click OK to connect.

If the connection is successful, a message stating Hub: Logged in as username is displayed in the Workbench status bar. If the connection fails, an error message is displayed in the Hub Login dialog box.

Working with views

This section describes how to manipulate the Workbench views both individually and as part of overall view stacks (page 61).

View stacks

A view stack is a window formed by a collection of views that are all allocated the same area in a perspective.
You can move, minimize and maximize views using a view stack. When a view is reopened, that view opens in the view stack to which it was last attached.

For example, the view stack below contains two views:

![View Stack Example](image)

**Resizing a view**

In order to resize a view, you have to resize its associated view stack, which will then resize all the views within it.

1. Move your mouse over the border between the particular view stack or window, and its adjacent view stack or window (whether this is to the side, above or below), until the cursor changes to the or resize icon.
2. Press your left mouse button and keep it pressed while you drag the border side to side, or up and down.
3. Release the mouse button to complete the resize operation.

**Minimising a view**

To minimise a view, you have to minimise its associated view stack. The minimised views are represented by icons on either the left or right of the Workbench, so that you can restore them:
To minimise a view stack or window, click the **Minimise** button on the view stack or window.

**Maximising a view**

To maximise a view, you have to maximise its associated view stack, which fills the Workbench interface.

Maximising a view causes it to occupy all available space in the Workbench window. All other view stacks are minimised to the edges of the Workbench window, where they are represented as icons.

To maximise a view stack or window, click the **Maximise** button on the view stack or window.

**Restoring a view**

To restore a view to its 'normal' state after it has been minimised or maximised, you have to restore its associated view stack.

To restore a view stack or window that has been maximised, click on the **Restore** button on the view stack or window.

To restore a view stack or window that has been minimised, click the **Restore** button above the minimised view stack to restore all the views in that stack.

**Open a view**

To open a view:

1. Click the **Window** menu, click **Show View** and then click **Other**.

2. In the **Show View** dialog box, either enter the view name or select the required view from the list of views. Click **OK** to display the view
The view is opened in the view stack to which it was last attached. If the required view is already open, it will become active in Workbench.

**Detach and re-attach a view**

You can move a view between view stacks in Workbench or into a new detached window.

**To detach a view:**

Click on the view tab or title bar and drag the view to a different view stack. Alternatively, drag the view away from the Workbench window to create a new view stack. If you close a detached view stack, it will still be detached when you next open it.

**To attach a view to a view stack:**

Click on the view tab or title bar and drag the view over the required view stack. Use the guides to position the view in the view stack.

**Perspectives**

The positions of available views, windows, view stacks, menu items, and toolbars, together with any other items that make up the general layout of Workbench, together constitute a perspective.

The default WPS perspective (page 16) can be customised by moving, resizing, adding or removing different views. You can save customised perspectives and to switch between different Workbench perspectives.

When you open Workbench, the windows views, toolbars and the so on, are displayed in the same arrangement as when closed. This ensures that your preferred perspective is visible when you open Workbench.

**Open a perspective**

To open a different perspective:

1. Click the Window menu click **Open Perspective** and then click **Other**.
2. In the **Open Perspective** dialog box, select the required perspective from the list and click **OK**.

The selected perspective is displayed in Workbench. If you have other perspectives available, they are listed in top right of the Workbench, so that you can click switch between them quickly.
Close a perspective

The quickest way to close a perspective is to go to the area to the right of the **Open Perspective** icon, right-click on the perspective required, and then select **Close**. Alternatively:

1. If you have more than one perspective open, ensure that the Workbench is displaying the one that you want to close.

   **Note:**
   To switch perspective, look in the area to the right of the **Open Perspective** icon, and then click on the perspective required.

2. Select **Window ➤ Close Perspective**.

   **Note:**
   To close all the perspectives, so that only the **Default WPS perspective** (page 16) remains available for selection, select **Window ➤ Close All Perspectives**. Your interface will go blank. To restore the default perspective, select **Window ➤ Open Perspective ➤ Other ➤ WPS (default)**.

Resetting a perspective

You can reset the current perspective back to its default layout at any time, by proceeding as follows:

1. Select **Window ➤ Reset Perspective**.

2. You are prompted for confirmation that you wish to reset the perspective. Click **Yes** to confirm that you wish to do so.

Saving a perspective

If you have changed the layout of a perspective, you can save it under a user defined name for future use, as follows:

1. Select **Window ➤ Save Perspective As...**

2. Enter a name for the perspective at the top of the **Save Perspective As...** dialog.

3. Click **OK** to continue.

The new perspective appears in the top right of the Workbench, to the right of the **Open Perspective** icon.

**Note:**
A perspective derives its icon from the one that you had open when you saved it.
Deleting a perspective

To delete a perspective:

1. Select **Window** ➤ **Preferences**.
2. From the left hand tree view of the **Preferences** window, select **General** ➤ **Perspectives**.
3. From the list of **Available perspectives**, click on the perspective that you want to delete.
4. Click **Delete** to remove the perspective permanently. There is no confirmation prompt.

**Note:**
You can only delete user-defined perspectives. In other words, you cannot delete a perspective that was supplied with WPS, including the default **WPS** perspective.

5. Click **OK** to close the **Preferences window**.
Create a new program

You can create a new program under either the Project Explorer or File Explorer.

To create an empty program file in Workbench:

1. Click the **File** menu, click **New** and then click **Untitled Program**.
2. Enter the following example to create a simple dataset:

```sas
/* Create a dataset */
DATA employees;
LENGTH Name $10 Age 3 Job $15;
INPUT Name $ Age Job $;
/* Here is the data */
CARDS;
Beth 41 Sales-Manager
Steve 32 Sales
William 35 Accounts
Anne 28 Marketing
Dawn 26 Sales
Andrew 36 Support
;
```

Workbench displays the language elements in the program using colour coding to help you to see the structure of the code, for example:
3. Click the **File** menu and then click **Save as** to save your program. Use the **Save as** dialog box to select the parent folder and enter a **File name** for the program.

4. Click the **File** menu, click **Run Program** and then click **Local server** to run the program.

   The generated dataset is created in the **WORK** library of the local server, displayed in the **WPS Server Explorer view**:

   ![WPS Server Explorer view](image)

   You can view the dataset properties, or open and edit the dataset in the **Editor view** (see Editing a dataset (page 92) for more information).

---

**Creating a new program file in a project**

To create a new program file:

1. Click the **File** menu, click **New** and then click **New Program** to launch the **New Program** wizard.

2. Select the required parent folder at the top of the dialog, and enter a **File name**.

3. If you are creating a new program in a project, you can create a link to an existing program on the file system:
   a. Click **Advanced** and select **Link to file in the file system**.
   b. Click **Browse** and use the **Select Link Type** window to locate the file and click **Open**.

4. Click **Finish** to complete the task.

   The new program is automatically opened in the **Editor view**.

Alternatively, you can create an untitled program, and save the program when required. To create an untitled program, click the **File** menu, click **New** and then click **Untitled Program**.
Entering WPS code via templates

You can define templates that can be entered as code shortcuts into programs. These templates can be accessed through the normal code completion key sequence (typically, \texttt{CTRL+Space}). For example, if you define a code template with the name \texttt{template1}, you can type \texttt{temp} followed by \texttt{CTRL+Space} and the code completion feature will execute the following actions:

1. Match \texttt{temp} against the list of code templates.
2. Find your template called \texttt{template1}.
3. Enter the \texttt{Pattern} associated with the template into your program.

The \texttt{Pattern} containing the code to be entered into your program can be as simple or as complex as you like. It could just be a single word. For example, you could define a code template to expand to the name of a frequently used dataset for which the name is difficult to type. A code template could also define a large amount of text, for example, a boilerplate invocation of a particular procedure. If you are entering a variable into a \texttt{Pattern}, it needs to be enclosed within pairs of "$" characters.

You can export code templates to an external file, or import them from a previously exported file. This allows you to share code templates, or to copy code templates between workspaces.

WPS Code Injection

You can create SAS language code to be run before or after your program using the Workbench code injection feature. The code to run is entered in the Code Injection panel of the Preferences window.

**Enable custom pre-code injection**

When this option is selected, the code in the text box is executed immediately prior to the running of a program. This option is similar to the \texttt{INITSTMT} system option, except that this code is automatically run before each submitted program. (The \texttt{INITSTMT} system option is only processed on server startup).

**Enable custom post-code injection**

When this option is enabled, the code in the text box is executed immediately following the running of a program. This option is similar to the \texttt{TERMSTMT} system option except that this code is automatically run after each submitted program. (The \texttt{TERMSTMT} system option is only processed on server shutdown.)

Using Program Content Assist

The SAS Language editor provides a content assistance feature that suggests language elements. When you select these elements, they are automatically added to your program:
1. Type a keyword into a program that may be associated with language elements.  
   For example, type the word PROC.

2. After the word, type a single space character and press CTRL+SPACEBAR.
   
   If there are any expected language elements after the word you typed, a popup list is displayed of these elements.

3. You can filter the list by typing in the first few letters of the language element that you want to use.

4. Double-click the language element you require and it will added to your program.

**WPS syntax colouring**

Workbench preferences SAS language Syntax can be modified to provide your preferred color scheme in the SAS language editor. To modify the syntax colouring:

1. Click the Window menu and then click Preferences.

2. In the Preferences window, expand the WPS group and select Syntax Colouring.

3. For each different type of language item, specify attributes relating to Color, Background Color and whether the item should be displayed in **Bold** or **Italic**.

4. Click OK to save the changes and close the Preferences window.
Run a program

You can run a program from either inside the Workbench or a command line outside of the Workbench.

All libraries, datasets and macro variables are *persistent*. This means that, once they are assigned during the execution of a program, they are available to other programs that are run during the same Workbench session.

If required you can clear all previous libraries, datasets, variables and output on a WPS server for the current session by restarting the server (see Restart the server (page 33)). Alternatively you can use the Clear Log, Clear Results options on the WPS menu to reset the log and program output respectively.

For more information about controlling the output (datasets, logs, results, and so on) generated from the execution of a program see Working with program output (page 98).

Run a program in Workbench

When you run a program, the state from previous program executions run on the same WPS server, in the same server session, is preserved, so the program can interact with the datasets, Filerefs, and so on, that have been previously created.

To run a program in Workbench:

1. Ensure that the program to be run is open and active in the Editor view.

2. Click the WPS, click Run selected code from <pathname> and then click Local Server (Substitute the name of your remote WPS server in place of Local Server). Alternatively use the Ctrl + R shortcut key.

Alternatively, you can select and run an unopened SAS language program in either the Project Explorer or File Explorer and click Run on in the shortcut menu.

Run part of a program

You can execute part of a SAS language program as follows:

1. Ensure that the relevant program is open and active in the Editor view.

2. Highlight the section of code in the program that you want to execute.

3. Click the WPS, click Run selected code from <pathname> and then click Local Server (Substitute the name of your remote WPS server in place of Local Server). Alternatively use the Ctrl + R shortcut key.
Stop program execution

To stop SAS language program before it has finished:

1. Click the WPS menu, click Cancel and then click Local Server (Substitute the name of your remote WPS server in place of Local Server) to stop program execution.

2. Once the progress indicator in the lower right corner of the Workbench disappears, this indicates that the program has stopped running.

Depending on the particular step that the program is executing, the program may not stop immediately.

When the program stops, a message similar to ERROR: Execution was cancelled is displayed in the log.

WPS Preferences for running programs

Preferences used to control the behaviour of Workbench during program execution.

The WPS page of the Preferences contains options affecting how SAS language programs are run. Before running any programs, select your preferred settings from the page:

Save all modified files before running a program

Specifies whether modified programs open in the Editor view are saved before a program is run. The behaviour can be one of: Always, Never or Prompt. The default, Prompt, displays the Save and Run dialog box listing modified files.

• If you select Always save resources before run, all modified files open in the Editor view are saved before the program is run.

• If you select Never save resources before run, no changes to files open in the Editor view are saved before the program is run. Errors may occur if your program relies on other files open in Workbench that have been modified but not saved.

Close all open datasets before running a program

Specifies whether open datasets are closed before running a program. The behaviour can be one of: Always, Never or Prompt. The default, Prompt, displays the Datasets are open dialog box listing all opened datasets.

• If you select Always close datasets before run, all open datasets are closed before the program is run.

• If you select Never close datasets before run, all datasets are left open when the program is run. This may cause errors if the program attempts to modify an open dataset
Show log when an error is encountered running a program

Specifies whether the log file is displayed when an error is encountered in a program. The behaviour can be one of: Always, Never or Prompt. The default, Prompt, displays the Confirm Log Display dialog box:

- If you select Remember my decision, the log file is always shown whenever an error is encountered.
- If you clear Remember my decision, the log file is never shown whenever an error is encountered.

Close all open datasets when deassigning a library

Specifies whether open datasets are closed when the containing library is deassigned. The behaviour can be either Always or Prompt. The default, Prompt, displays a dialog listing open datasets that must be closed to de-assign the library.

Confirm deletions

Specifies whether confirmation is required when deleting an item in the WPS Server Explorer view.

Confirm server restart

Specifies whether confirmation is required when you restart a server in the WPS Server Explorer view.

Autoscroll the log

Specifies whether the log output is automatically scrolled (see View the log (page 99)).

Autoscroll the listing

Specifies whether the listing output is automatically scrolled (see View the listing output (page 101)).

Show advanced server actions

Controls the context menu options available when restarting WPS servers (see Restarting with Advanced Server Actions (page 33)).

Temporary file location

This field points to the directory where the Workbench stores temporary files. The log files created during execution of a program are stored in this directory, as are any ODS HTML results generated by programs.

You should be aware that output files, particularly logs, can be sizeable, and so may find that you need to modify this setting if the field points by default to a location with space restrictions.
Command line mode

Running SAS language programs on a WPS server from the command line.

To use the WPS server from a command line, you need to execute the `wps` program. This executable file is located in the `bin` directory of your WPS installation.

When running the WPS server from a command line, you cannot compile programs into run-time jobs.

Options

Running `wps` on its own will not do anything, and so you will need to pass some additional instructions in the following form:

```
wps <options> <programFileName>
```

The `<options>` arguments can be a list of any of the following:

- `-optionname [optionalValue]` — specifies a WPS system option.
- `-config <configFileName>` — specifies a configuration file containing WPS system options
- `-set <envVarName> <envVarValue>` — specifies an environment variable that takes effect when the WPS server is run.

You can define any number of `<options>` arguments, but the `<programFileName>` must always be the last argument on the command line.

System options

To set a system option specify:

```
wps -optionname [optionalValue] <programFileName>
```

You can pass as many `-optionname` system options to the WPS server as required. However, you can only pass single value options, so must specify `-optionname [optionalValue]` for each system option.

Configuration files

System options can be defined in a configuration file, and this file referenced when running the WPS server:

```
wps -config <configFileName> <programFileName>
```

For more information about configuration files and the order in which they are processed, see `Configuration files` (page 115).
Environment variables

To set an environment variable to use with the WPS server:

```
wps.exe -set <envVarName> <envVarValue> <programFileName>
```

You can set as many environment variables as you require. However, you can only pass single value options, so must specify `-set <envVarName> <envVarValue>` for each environment variable.

Log output

When you run the WPS server from the command line, log information is sent to the standard output (`stdout`) for the operating system. Once the program has finished running this log information is lost. To preserve the log output, redirect `stdout` to a file, for example:

```
wps program1.sas > program1.log
```

Results output

When you run the WPS server from the command line, any results generated by the program are automatically captured into a file called `<programFileName>.lst` created in the same directory as the program. For example, a file called `Program1.lst` is output if you run a program called `Program1.sas`. 
Libraries and datasets

A library is used to store WPS data files (including datasets), folder locations and database connections via the LIBNAME statement.

On the majority of operating systems, a library maps directly to an operating system folder. The operating system folder may contain non-WPS files, but only the files with extensions that WPS recognises will be visible in Workbench.

The default Libraries that are visible under each server in the WPS Server Explorer view are:

- **SASHELP** – a read-only library containing a variety of system metadata.
- **SASUSER** – used to store datasets and other information that you want to keep beyond the end of your WPS session. To use this location, add `SASUSER` in front of the name of the relevant dataset in your program.
- **WORK** – where your datasets, catalogs and Filerefs are stored by default. **WORK** is a 'temporary working space' that is automatically cleared of all data when your WPS server session ends.

To preserve output your program creates, you can redefine the work location to a non-temporary location (see Set WORK location (page 76)), or use the LIBNAME statement to write output you want to keep, to your own permanent location (such as a directory or database connection), for example:

```
LIBNAME mylib '/directories/mydirectory/';
```

Any directory or database connection that you associate with the alias must already exist before you assign it. Once a dataset has been created and stored in this location, the associated alias (`mylib`) must be used to retrieve the dataset.

Set WORK location

Change the WORK location when SAS language programs are run in Workbench.

To set the pathname for the WORK location that is used every time you start up a particular server:

1. In the WPS Server Explorer view, right-click the required server and click Properties in the shortcut menu.
2. In the properties list, expand the Startup group and select System Options.
3. On the System Options panel, click Add to display the Startup Option dialog box.
4. In Name enter `WORK`, and in Value enter the full pathname for the new WORK location.
5. Click OK to save the system option, and click OK on the Properties dialog box to restart the server and apply your changes.
The `WORK` location is redefined when using Workbench to run SAS language programs, but not if WPS is run from the command line. When running programs in batch mode, the `WORK` system option must be set in a configuration file.

## Catalogs

A catalog is a folder in which you can store different types of information (called catalog entries), for example formats, informats, macros, and graphics output.

For example, you could write a program to generate a catalog (FORMATS) in which to store PICTURE formats:

```sas
PROC FORMAT;
  PICTURE beau  0-HIGH = '00 000 000.09' ;
  PICTURE beaul 0-HIGH = '00 000 000.09' ;
RUN;
PROC CATALOG CATALOG = WORK.FORMATS;
  CONTENTS;
RUN;
```

The PICTURE statement allows you to create templates for printing numbers by defining a format that allows for special characters, such as leading zeros, decimal and comma punctuation, fill characters, prefixes and negative number representation.

When you run the program, the catalogs are created under the `WORK` folder:

![Catalogs folder](image)

To view the entries associated with the catalogs, right-click on them and click Properties.
Datasets

A dataset is a file created or imported by a WPS server, and stored in a library (see Libraries and datasets of page 76). It contains rows and columns known as observations and variables respectively.

Observations (rows) usually relate to one specific entity (for example, an order or person).

Variables (columns) describe attributes of an entity (for example, an item ID in an order).

Example Dataset

In this example dataset, each observation is an item in the order. The variables are Order ID, Item ID, Quantity and Unit Price.

<table>
<thead>
<tr>
<th>Order ID</th>
<th>Item ID</th>
<th>Quantity</th>
<th>Unit Price</th>
</tr>
</thead>
<tbody>
<tr>
<td>10001</td>
<td>47953</td>
<td>3</td>
<td>30.75</td>
</tr>
<tr>
<td>10001</td>
<td>23104</td>
<td>10</td>
<td>4.90</td>
</tr>
<tr>
<td>10002</td>
<td>62091</td>
<td>1</td>
<td>89.99</td>
</tr>
</tbody>
</table>

Open a dataset

You can open a dataset in the WPS Server Explorer view. Expand the required server node, expand Libraries and double-click the required dataset.

Delete a dataset

You can delete a dataset stored on disk in the WPS Server Explorer view. Expand the required server node, expand Libraries node and expand the required library. Select the dataset, right-click and click Delete in the shortcut menu.

Import datasets

In addition to the datasets created by running SAS language programs, datasets can be created by importing data from external files. The supported formats are:

- Delimited
- Fixed Width
- Microsoft Excel Spreadsheet Files

The Dataset Import Wizard enables you to configure the dataset as it is imported. It is not always necessary to go through all of the steps in the wizard; you can import a dataset from a file and click Finish on the first page to accept all the default options. If you import a dataset with the same name as an existing one, you will overwrite it.
When importing delimited files, Workbench determines the delimiter character from the data. If this delimiter is not correct, you can change it prior to importing the dataset.

When importing fixed width files, Workbench determines column start and end from the data. If these widths are not correct, you can change the widths prior to importing the dataset.

Spreadsheet files may contain several worksheets. By default, the Workbench will select the first sheet with data for importing. A sheet may also have names that refer to cell ranges, and it is possible to import data from these names, and also from the clipboard.

You can drag a dataset file from the Project Explorer or File Explorer to the required library on the WPS Server.

- You can only drag files from the Project Explorer to the Local Server.
- You can drag datasets from any folder accessed through the same connection node as the required WPS server. You cannot, for example, drag a Workbook from your Local connection to a remote connection. To do this first use the File Explorer to copy the dataset to the required server, and then drag the dataset from the new location.

You can also import a dataset using one of the following methods:

- Programatically, for example using the XLSX engine:

  ```plaintext
  LIBNAME xlsxlib XLSX ‘myfile.xlsx’ HEADER=YES;
  DATA WORK.IMPORTED;
  SET xlsxlib.Sheet1;
  RUN;
  ```

- The Dataset Import Wizard. When importing Excel Workbooks in either XLS or XLSX format, this method uses the EXCEL engine and you will therefore need to have the Microsoft ACE OLEDB engine installed.

  If you do not have Microsoft Excel installed, you will need to install the Microsoft Access Database Engine Redistributable to import datasets.

### Import datasets from files

To import files:

1. In the WPS Server Explorer view, right-click local server and click Import Dataset on the shortcut menu.

   Alternatively, you can select a file in from the file system and either drag the file to the local server or copy and paste the file to the local server.

2. In the Dataset Import dialog box, enter a file name or click Change and open the required file.

3. Select a Library Name for the dataset and, if required, change the Member Name to rename the dataset

4. The type of format is inferred from the type of file imported. If required, change the type of Data Format that best describes the dataset content.
5. Click **Next** and Configure the imported dataset depending on the type:

- **If you select Fixed width**, for each **Column** modify the **Start** value and **Width** value to alter the width of the exported variable.
- **If you select Delimited**
  - Select the required delimiter. To define your own delimiter, select **Other** and enter the delimiter character.
  - Select **Include field names on first row** to include the names of the columns.
- **If you select Excel**
  - **If required, select a different worksheet in Whole Worksheet.** You can also select an existing **Named Range** from the existing or new worksheet
  - Select **Include first row names as column headers** to use the first row as variable names.

6. Click **Next** and, if required, edit the dataset column properties.

- To change a column name, select a column header in the preview and edit the **Column Name**.
- To change a column label, select a column header in the preview and edit the **Column Label**.
- To change the column data type, select a column header in the preview edit the **Column Data Format**.

7. Click **Finish** to import the dataset

**Import spreadsheet data**

You can use the **Dataset Import Wizard** to import range of cells directly from a Microsoft Excel spreadsheets.

Data imported will have the last-saved value. Cell formulae are not reevaluated when the spreadsheet is opened, and the last-saved value is used for these cells.

1. Select the contiguous range in your Excel spreadsheet that you want to import. and copy and paste the content to the required server in the **WPS Server Explorer** view.

   Alternatively, you can drag the selected range to the required library in the required server.

2. In the **Dataset Import** dialog box, enter a file name or click **Change** and open the required file.

3. Select a **Library Name** for the dataset and, if required, change the **Member Name** to rename the dataset

4. The type of format is inferred from the type of file imported. If required, change the type of **Data Format** that best describes the dataset content.

5. Click **Next** and Configure the imported dataset depending on the type:

- **If you select Fixed width**, for each **Column** modify the **Start** value and **Width** value to alter the width of the exported variable.
- **If you select Delimited**
• Select the required delimiter. To define your own delimiter, select Other and enter the delimiter character.
• Select Include field names on first row to include the names of the columns.

6. Click Next and, if required, edit the dataset column properties.
   • To change a column name, select a column header in the preview and edit the Column Name.
   • To change a column label, select a column header in the preview and edit the Column Label.
   • To change the column data type, select a column header in the preview edit the Column Data Format.

7. Click Finish to import the dataset

Export datasets

WPS datasets can be exported as delimited and fixed width text, and also as Microsoft Excel Workbooks. The Dataset Export Wizard allows you to fine tune the contents of export file as required.

To export a dataset:
1. In the WPS Server Explorer view, expand the required server, right-click the required dataset and click Export Dataset on the shortcut menu.
2. In the Dataset Export Wizard, select the export type, one of: Delimited, Fixed Width or Excel. For Excel, select the required file format and click Next.
3. Configure the exported dataset depending on the export type:
   If you select fixed width, for each Column modify the Start value and Width value to alter the width of the exported variable.
   If you select Delimited:
   • Select the required delimiter. To define your own delimiter, select Other and enter the delimiter character.
   • Select Include field names on first row to include the names of the columns.
4. In the Select Destination File panel, enter a file name for the exported dataset and click Finish

Remove dataset reference

You cannot remove a dataset reference on its own. To remove a dataset reference, you must restart the required server, which also removes any ODS output, log entries, other libraries, and file references. For more information, see Restart the server (page 33).
Data Profiler view

The Data Profiler view enables you to view content and details about a dataset.

To open the Data Profiler view, select the required working dataset, right-click Open With and then click Data Profiler in the shortcut menu.

Summary View

The Summary View lists information about the dataset, including number of observations and variables in the dataset and variable characteristics.

The Summary View contains two panels, Summary and Variables.

Summary

The Summary panel displays summary information about the dataset: the dataset name, the total number of observations, and the total number of variables in the dataset.

Variables

The Variables panel displays information about the variables in the dataset, such as the variable name, label type, length, and so on. The following information is displayed:

Variable
The name of the variable in the dataset.

Label
The alternative display name for the variable.

Type
The type of the variable. The type can be either Numeric for numbers and date and time values, or Character for character and string data.

Classification
The category of the variable; this can be one of:

- Categorical. A variable that can contain a limited number of possible values, and the limit is below the specified classification threshold.
- Continuous. A variable that can contain an unlimited number of possible values. This classification is used for numeric variables where the number of distinct values in the variable is greater than the specified classification threshold.
- Discrete. A variable that can contain a limited number of possible values. This classification is used for character variables where the number of distinct values in the variable is greater than the specified classification threshold.
The classification threshold is specified on the **Data** panel of the **Preferences** dialog box.

**Length**
The size required to store the variable values. For character types, the number represents the maximum number of characters found in a variable value. For numeric types, the number represents the maximum number of bytes required to store the value.

**Format**
How the variable is displayed when output. For more information about formats see the section **Formats** in the *WPS Reference for Language Elements*.

**Informat**
The formatting applied to the variable when imported into WPS. For more information about formats see the section **Informats** in the *WPS Reference for Language Elements*.

**Distinct Values**
The number of unique values in the variable. If the variable classification is Continuous, the display indicates there are more unique values than the specified classification threshold.

**Missing Values**
The number of missing values in the variable.

**Frequency Distribution**
For each value in a non-continuous variable, displays a chart showing the number of occurrences for each value in the variable.

**Data**
The **Data** panel lists all observations in a dataset and enables you to view, filter, or sort the observations.

The **Data** panel in the **Data Profiler** view is a read-only version of the **Dataset Viewer**. You can modify the view, sort and filter data in the **Data** panel. If you want to edit values in the dataset, you need to use the **Dataset Viewer**.

**Univariate View**
The **Univariate view** tab displays summary statistics for all numeric univariate variables.

The columns displayed in the **Univariate View** tab are determined using the **Calculate Statistics** dialog box. Click **Configure Statistics** to open **Preferences** and select the statistics you want displayed:

**Quantiles**
Lists quantile points.
Variable Structure
Lists each of the selected principal statistics describing the variable, such as number of missing values, and minimum and maximum values.

Measures of Central Tendency
Lists each of the measures used to identify the central point in the values of the variable.

Measures of Dispersion
Lists each of the selected measures used to show the variation from the central value in the variable.

Others
Lists other statistics that can be displayed in the statistics table.

Univariate Charts

The Univariate Charts tab enables you to view the frequency distribution table and graphs for a selected dataset variable.

The information displayed is determined by the variable selected in the Variable Selection list. Each section in the tab displays the frequency of values occurring in the selected variable.

Frequency Table
Displays the frequency of the values in the specified variable, the percentage of the total number of observations for each value, and cumulative frequencies and percentages.

If the variable type is categorical or discrete, the table displays one row for each potential value. If the variable type is continuous, the variable is binned and the frequency information is displayed for each bin.

Frequency Chart
The frequency distribution of the specified variable can be displayed as a histogram, line chart or pie chart. In all cases, the charts display the frequency of values as the percentage of the total number of observations for the variable.

The chart can be edited and saved. Click Edit chart to open the Chart Editor from where the chart can be saved to clipboard.
Correlation Analysis

The Correlation Analysis tab enables you to view the strength of the relationship between numeric variables in the dataset.

Options

Specifies the coefficient type to use when comparing variables, and which numeric variables in the dataset are to be compared.

Coefficient

Specifies the type of coefficient used to compare values.

Pearson

Specifies Pearson correlation coefficient, defined as:

$$ r_{xy} = \frac{\sum_{i=1}^{n}(x_i - \bar{x})(y_i - \bar{y})}{\sqrt{\sum_{i=1}^{n}(x_i - \bar{x})^2 \sum_{i=1}^{n}(y_i - \bar{y})^2}} $$

where

$$ \bar{x} = \frac{1}{n} \sum_{i=1}^{n} x_i $$

is the mean of variable $x$

$$ \bar{y} = \frac{1}{n} \sum_{i=1}^{n} y_i $$

is the mean of variable $y$.

Spearman’s Rho

Specifies Spearman’s rank correlation coefficient, defined as:

$$ r_s = \frac{\sum_{i=1}^{n}(R_{x_i} - \bar{R}_x)(R_{y_i} - \bar{R}_y)}{\sqrt{\sum_{i=1}^{n}(R_{x_i} - \bar{R}_x)^2 \sum_{i=1}^{n}(R_{y_i} - \bar{R}_y)^2}} $$

where

• $R_{x_i}$ is the rank of $x_i$

• $\bar{R}_x = \frac{1}{n} \sum_{i=1}^{n} R_{x_i}$ is the mean of the ranked variable $R_x$.

• $R_{y_i}$ is the rank of $y_i$

• $\bar{R}_y = \frac{1}{n} \sum_{i=1}^{n} R_{y_i}$ is the mean of the ranked variable $R_y$.

The values of the variables are first ranked and the ranks compared. Using this coefficient may therefore be more robust to some outliers in the data.
Kendall’s Tau

Specifies the Kendall rank correlation coefficient, defined as:

$$\tau_b = \frac{n_c - n_d}{\sqrt{n_0 - n_1}(n_0 - n_2)}$$

Where

• $n_0 = \frac{n(n - 1)}{2}$
• $n_1 = \sum_{i=1}^{n} t_i(t_i - 1)/2$
• $n_2 = \sum_{j=1}^{n} u_j(u_j - 1)/2$

- $n_c$ is the number of concordant pairs.
- $n_d$ is the number of discordant pairs.
- $t_i$ is the number of tied values in the $i$th group of tied values for the first variable.
- $u_j$ is the number of tied values in the $j$th group of tied values for the second variable.

The difference in the number of concordant and discordant pairs can be expressed as:

$$n_c - n_d = \sum_{i<j} \text{sign}(x_i - x_j) \text{ sign}(y_i - y_j)$$

The values of the variables are first ranked and the ranks compared. Using this coefficient may therefore be more robust to some outliers in the data.

Select Variables

Displays a list of numeric variables in the dataset, from which you can select the variables to compare.

Correlation Coefficient Matrix

The matrix is shown in colour blocks, the size and colour of the blocks indicates the relationship between the compared variables. The scale for the items displayed ranges from 1 a strong positive correlation to -1 where there is a strong negative correlation.

Using variables that show a strong positive correlation may lead to the model becoming unstable as a small change in the variables may lead to a large change in the model.

If you are using the model for prediction, variables showing a strong positive correlation may be good predictors.
Correlation Statistics

Displays the correlation statistics and scatter plot for the item selected in the Correlation Coefficient Matrix. The table displays the variables being compared, the value for the specified coefficient type and the P-value for the comparison. The scatter plot displays all values in the dataset, using the same colour scale as the matrix, as either a plot or heat map if the number observations is very high.

Predictive Power

The Predictive Power tab enables you to view the predictive power of independent variables in the dataset in relation to the selected dependent variable.

The information displayed is determined by the variable selected as the Dependent Variable. Each section displays the relationship between the independent variables in the dataset and the specified Dependent Variable.

Statistics table

The Statistics Table displays all the variables in the dataset and a series of predictive power statistics to enable you to identify the most effective independent variables for the specified dependent variable. The statistics displayed are:

- Entropy Variance. Displays the Entropy Variance value for each variable in relation to the specified Dependent Variable.
- Chi Sq. Displays the Chi-Squared value for each variable in relation to the specified Dependent Variable.
- Gini. Displays the Gini Variance value for each variable in relation to the specified Dependent Variable.

For more information about how these values are calculated, see Predictive power criteria (page 88)

Entropy Variance Chart

Displays the bar chart of independent variables' entropy variance in relation to the specified Dependent Variable. The variables are displayed in order from the highest entropy variance to the lowest. The number of variables displayed in the chart is determined by the preferences set in the Data Profiler panel of the Preferences dialog box.

The chart can be edited and saved. Click Edit chart to open the Chart Editor, from where the chart can be saved to clipboard.

Frequency Chart

Displays the frequency of each value of an independent variable selected in the Statistics Table. The chart has two display modes:
• Click View whole data to display the overall predictive relationship between values of an independent variable selected in the Statistics Table the specified Dependent Variable.

• Click View breakdown data to display the frequency of each value of an independent variable, and its relationship to the outcomes for the specified Dependent Variable.

The chart can be edited and saved. Click Edit chart to open a the Chart Editor from where the chart can be saved to clipboard.

Predictive power criteria

Predictive power is a way of measuring how well a particular input variable can predict the target variable.

Pearson’s Chi-Squared statistic

Pearson’s Chi-squared statistic is a measure of the likelihood that the value of the target variable is related to the value of the predictor variable.

Each observation in the dataset is allocated to a cell in a contingency table, according to the values of the predictor and target variables. Pearson’s Chi-squared statistic is calculated as the normalised sum of the squared deviations between the actual number of observations in each cell, and the expected number of observations in each cell if there were no relationship between the predictor and target variables.

If a predictor variable has a high Pearson’s Chi-squared statistic, it means that the variable is a good predictor of the target variable, and is likely to be a good candidate to use to split the data in a binning or tree-building algorithm.

Pearson’s Chi-squared statistic for a discrete target variable is calculated as

$$X^2 = \sum_{i=1}^{r} \sum_{j=1}^{c} \frac{(n_{ij} - \mu_{ij})^2}{\mu_{ij}}$$

where:

• $N$ is the total number of observations in the dataset

• $r$ is the number of distinct values of the predictor variable $X$ (these are the rows in the contingency table)

• $c$ is the number of distinct, discrete values of the target variable $Y$ (these are the columns in the contingency table)

• $n_{ij}$ is the number of observations for which the predictor variable $X$ has the $i$ th value, $X_i$, and the target variable $Y$ has the $j$ th value, $Y_j$ (these are the values in the cells of the contingency table)

• $n_i$ is the total number of observations for which the predictor variable $X$ has the $i$ th value, $X_i$
• $n_{i,j}$ is the total number of observations for which the target variable $Y$ has the $j$th value, $Y_j$
• $\mu_{i,j}$ is the expected value of $n_{i,j}$, calculated as
  \[ \mu_{i,j} = \frac{n_r n_{i,j}}{N} \]

**Entropy Variance**

Entropy variance is a measure of how well the value of a predictor variable can predict the value of the target variable.

If a variable in a dataset has a high entropy variance, it means that the variable is a good predictor of the target variable, and is likely to be a good candidate to use to split the data in a binning or tree-building algorithm.

Entropy variance for a discrete target variable is calculated as

\[
E_r = 1 - \sum_{i=1}^{r} \left( \frac{n_{r} E_i}{N} \right)
\]

where:
• $N$ is the total number of observations in the dataset
• $r$ is the number of distinct values of the predictor variable, $X$
• $c$ is the number of distinct, discrete values of the target variable
• $n_{i,j}$ is the number of observations for which the predictor variable $X$ has the $i$th value, $X_i$, and the target variable $Y$ has the $j$th value, $Y_j$
• $n_r$ is the total number of observations for which the predictor variable $X$ has the $i$th value, $X_i$
• $n_{r,j}$ is the total number of observations for which the target variable $Y$ has the $j$th value, $Y_j$
• $E_i$ is the entropy calculated for just the observations where the predictor variable is $X_i$, calculated as
  \[
  E_i = -\frac{1}{\log(c)} \sum_{j=1}^{c} \frac{n_{i,j}}{n_r} \log \left( \frac{n_{i,j}}{n_r} \right)
  \]
  • $E$ is the entropy calculated for all the observations, calculated as
  \[
  E = -\frac{1}{\log(c)} \sum_{j=1}^{c} \frac{n_{r,j}}{N} \log \left( \frac{n_{r,j}}{N} \right)
  \]

**Gini Variance**

Gini variance is a measure of how well the value of a predictor variable can predict the target variable.
If a variable in a dataset has a high Gini variance, it means that the variable is a good predictor of the target variable, and is likely to be a good candidate to use to split the data in a binning or tree-building algorithm.

Gini variance for a discrete target variable is calculated as

$$G_r = 1 - \frac{\sum_{i=1}^{r} \left( \frac{n_i}{n} G_i \right)}{G}$$

where

- $N$ is the total number of observations in the dataset
- $r$ is the number of distinct values of the predictor variable, $X$
- $c$ is the number of distinct, discrete values of the target variable, $Y$
- $n_{ij}$ is the number of observations for which the predictor variable $X$ has the $i$ th value, $X_i$, and the target variable $Y$ has the $j$ th value, $Y_j$
- $n_i$ is the total number of observations for which the predictor variable $X$ has the $i$ th value, $X_i$
- $n_j$ is the total number of observations for which the target variable $Y$ has the $j$ th value, $Y_j$
- $G_j$ is the Gini impurity calculated for just the observations where the predictor variable is $X_i$, calculated as

$$G_j = 1 - \frac{\sum_{j=1}^{c} n_{ij}^2}{n_i^2}$$

- $G$ is the Gini impurity calculated for all the observations, calculated as

$$G = 1 - \frac{\sum_{j=1}^{c} n_{j}^2}{N^2}$$

**Information value**

Information value is a measure of the likelihood that the value of the target variable is related to the value of the predictor variable. The information value measure is only applicable for binary target variables (that is, target variables that can take one of exactly two values).

If a predictor variable has a high information value, it means that the variable is a good predictor of the target variable, and is likely to be a good candidate to use to split the data in a binning or tree-building algorithm.

The information value statistic is calculated as

$$IV = \sum_{i=1}^{r} \left( \frac{n_{i0}}{n_0} - \frac{n_{i1}}{n_1} \right) WOE_i$$

where:
• $r$ is the number of distinct, discrete values of the predictor variable $X$ (these are the rows in the contingency table)

• $Y_0$ and $Y_1$ are the two possible values of the binary target variable $Y$

• $n_{i0}$ is the number of observations for which the predictor variable $X$ has the $i$th value, $X_i$, and the target variable $Y$ has the value, $Y_0$ (these are the values in the cells of the $Y_0$ column in the contingency table)

• $n_{i1}$ is the number of observations for which the predictor variable $X$ has the $i$th value, $X_i$, and the target variable $Y$ has the value, $Y_1$ (these are the values in the cells of the $Y_1$ column in the contingency table)

• $n_0$ is the total number of observations for which the target variable $Y$ has the value, $Y_0$

• $n_1$ is the total number of observations for which the target variable $Y$ has the value, $Y_1$

• $\alpha < 1$ is the weight of evidence (WOE) adjustment, a small positive number to avoid infinite values when $n_{i0} = 0$ or $n_{i1} = 0$

• $\text{WOE}_i$ is the WOE value for observations where the predictor variable is $X_i$, calculated as

\[
\text{WOE}_i = \ln\left(\frac{n_{i0}}{n_0 + \alpha}\right) - \ln\left(\frac{n_{i1}}{n_1 + \alpha}\right)
\]

**Dataset Viewer**

You can view, filter or sort a dataset within the viewer. You can also edit observation variables, remove observations, and also add new observations.

The contents of a dataset are shown in a grid. The rows of the grid represent dataset observations, and the columns represent dataset variables.

You can display labels in the column headers of a dataset, re-organise the view by moving columns, and if some of the datagrid columns are irrelevant for a task, you can hide them.

**Mode**

A dataset is opened in *Browse* mode, but can be converted to *Edit* mode if you want to make changes to the data. To edit the dataset content, click the Data menu and then click *Toggle Edit Mode*.

**Organising the dataset**

You can manipulate the view of the dataset so that you hide variables you do not need, and move columns so that they are in a different order. Any changes made in this view do not change the underlying data.
Show labels
You can specify whether to display labels for columns rather than column names. In the Preferences window click WPS, click Dataset Viewer and then click Show labels for column names.

Hide variables
To hide a datagrid column:
1. Right-click the column header for the variable you want to hide.
2. Click Hide column(s).
The datagrid column disappears from the view. If you hide a column for which filtering is currently active, you need to confirm that you want to remove the filter and hide the column.

Show hidden variables
To show previously hidden dataset variables:
1. Right-click the dataset header row.
2. Click Show / Hide Columns.
3. In the Show / Hide Columns dialog, select the columns to show and click OK.

Move columns
You can move columns in the dataset view:
1. Left-click and hold the mouse button on the column header.
2. Drag the column to where you want it to be.
   You will see a thick grey line appear between columns, indicating where the column will appear.
3. Release the mouse button, and the column appears in the indicated location.

Editing a dataset
You can edit observations, and also add and delete them, if the dataset is in Edit mode.
Controls for editing a dataset are available from the Data menu, from the toolbar, and also from the dataset context menu.
If the dataset is open in Browse mode, you can switch to Edit mode by clicking Edit:
You can make as many changes as required. Changes are not automatically written to the dataset, you must choose to save changes. If saving your changes fails, then any changes that were not written remain visible and details of the failure are written to the Workbench log.

### Modify observations

You can edit observation variables (cells) as raw values. If your variables have any formatting applied, you will not see this during editing; once edit is complete the formatted observation is displayed.

1. Double click the cell that you want to edit:

<table>
<thead>
<tr>
<th>Variable Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Numeric</td>
<td>The raw, unformatted value is displayed in the cell where you can enter a new value. If you want to see how the current cell appears when formatted, press <strong>Shift + F8</strong> and it will be shown as a tooltip.</td>
</tr>
<tr>
<td>DATE, DATETIME or TIME</td>
<td>DATE, DATETIME and TIME values are edited as their respective types. You can click on any individual element of a date or time (such as a year or hour) in-place, and use the keyboard arrow keys or mouse wheel to increase or decrease them in steps. Numeric elements can also be overtyped with replacement values. You can use the alternative edit control associated with each type. DATE values have a calendar, times have a time picker, and DATETIME values have a DATETIME picker combination. Click on the button to the right of the in-place value and the appropriate editor will appear.</td>
</tr>
<tr>
<td>String</td>
<td>The raw, unformatted value is displayed in the cell where you can enter a new value. If you want to see how the current cell appears when formatted, press <strong>Shift + F8</strong> and it will be shown as a tooltip.</td>
</tr>
</tbody>
</table>

2. When you have completed your edits, press **Enter**.
If the value you entered is different from the original saved value, then the observation value is displayed in bold type with an asterisk (*) next to the observation number in the left margin of the grid.

3. Changes are not saved to the dataset immediately. To save the changes to the original dataset, click the File menu, and then click Save. If the changes have been made in error, you can undo all edits (see Cancel changes (page 94)).

Add observations

New observations can be added to a dataset. They are always added to the end of the dataset, regardless of your current position within it. To add a new observation:

1. Click the Data menu and then click Add Observation.
2. The new row will appear in bold type, and a plus character (+) will appear next to the observation number in the left margin of the grid. Double-click each cell in the observation and modify the content as required.
3. Changes are not saved to the dataset immediately. To save the changes to the original dataset, click the File menu, and then click Save. If the changes have been made in error, you can undo all edits (see Cancel changes (page 94)).

Delete observations

To delete an observation from a dataset:

1. Select the observation that you want to delete by clicking on its observation number in the left hand column. To delete multiple observations, hold down the CTRL key while selecting the observations you want to delete.
2. Click the Data menu, and then click Delete Observation.
3. Changes are not saved to the dataset immediately. To save the changes to the original dataset, click the File menu, and then click Save. If the changes have been made in error, you can undo all edits (see Cancel changes (page 94)).

Cancel changes

You can cancel any changes that you have made but not yet saved. To cancel unsaved changes:

1. Click the Data menu and then click Cancel edits.
2. In the Confirm Cancel Edits, click Yes to undo any changes.
Missing values

You can set an observation variable to missing using the Set Missing option.

Note:
When numeric variables are formatted as DATE, DATETIME or TIME, this is the only way to set these variables as missing.

1. Select the observation variable (cell) you want to set as missing.
   Only one variable at a time can be set to missing in a single operation.

2. Right-click the selected cell, and click Set Missing in the shortcut menu.
   
   1. If the cell is a character variable type, the cell is set to a single space (" ") character.
   2. If the cell is a numeric variable type, the Set Missing Value dialog is used to set the missing value. If the observation variable is already set to a missing value, then the current raw value is shown. If the observation variable is not set to missing, the default . (full stop) value is used. If required, you can change the missing value to the value to one of: . (full stop), ._ (full stop followed by an underscore), or .A to .Z.

3. Changes are not saved to the dataset immediately. To save the changes to the original dataset, click the File menu, and then click Save. If the changes have been made in error, you can undo all edits (see Cancel changes (page 94)).

Filter a dataset

You can filter the contents of the dataset by variable to show only the data that you need. Filters are cumulative, if you filter on more than one variable, all filters apply. You can cancel any of the filters at any time.

You can set filter criteria on multiple columns and, as you apply filters, the dataset contents are automatically updated.

To filter your dataset view:

1. Click the filter button below the variable heading for the column that you want to filter.

2. Select the criteria by which you want to filter the view and Complete the criteria for the filter by entering the appropriate details.

<table>
<thead>
<tr>
<th>Data Type</th>
<th>Criteria</th>
</tr>
</thead>
<tbody>
<tr>
<td>DATE, DATETIME or TIME</td>
<td>Most expressions based on a date or time variable are set in another dialog. Use the calendar and clock controls to set the date criteria. For DATETIME values, click the clock button to set the time component of the filter value.</td>
</tr>
<tr>
<td>Other numeric or string</td>
<td>The expression for the filter is shown below the variable header. Enter the value or values necessary to complete the expression in the edit box.</td>
</tr>
</tbody>
</table>
For a list of supported filter expressions, see *Dataset filter expressions* (page 96).

To clear the filter for a variable, click the filter button and then click **Clear Filter**.

### Dataset filter expressions

For variable types other than DATE, DATETIME or TIME formats, you can edit the filter expression that is generated. You cannot edit the expressions of DATE, DATETIME or TIME variable filters; these can only be cleared and re-entered.

### Filter Expression Syntax

The table shows the supported expression syntax.

<table>
<thead>
<tr>
<th>Criteria</th>
<th>Expression</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td>Equal to</td>
<td>$EQ {x}$ or $EQ {s}$</td>
<td>Is equal to 100 (numeric)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>$EQ \text{100}$</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Is equal to &quot;Blanco&quot; (string)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>$EQ \text{&quot;Blanco&quot;}$</td>
</tr>
<tr>
<td>Not equal to</td>
<td>$NE {x}$ or $NE {s}$</td>
<td>Is not equal to 100 (numeric)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>$NE \text{100}$</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Is not equal to &quot;Blanco&quot; (string)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>$NE \text{&quot;Blanco&quot;}$</td>
</tr>
<tr>
<td>Less than</td>
<td>$LT {x}$</td>
<td>Is less than 100</td>
</tr>
<tr>
<td></td>
<td></td>
<td>$LT \text{100}$</td>
</tr>
<tr>
<td>Greater than</td>
<td>$GT {x}$</td>
<td>Is greater than 100</td>
</tr>
<tr>
<td></td>
<td></td>
<td>$GT \text{100}$</td>
</tr>
<tr>
<td>Less than or equal to</td>
<td>$LE {x}$</td>
<td>Is less than or equal to 100</td>
</tr>
<tr>
<td></td>
<td></td>
<td>$LE \text{100}$</td>
</tr>
<tr>
<td>Greater than or equal to</td>
<td>$GE {x}$</td>
<td>Is greater than or equal to 100</td>
</tr>
<tr>
<td></td>
<td></td>
<td>$GE \text{100}$</td>
</tr>
<tr>
<td>Between (inclusive)</td>
<td>BETWEEN ${x}$ AND ${y}$</td>
<td>Is between 100 and 200</td>
</tr>
<tr>
<td></td>
<td></td>
<td>BETWEEN $\text{100}$ AND $\text{200}$</td>
</tr>
</tbody>
</table>
### Sort a dataset

You can sort the contents of a dataset on several variables. Variables that are part of an active sort have an icon representing the direction of the sort in the header: ![ascending sort] for ascending sort and ![descending sort] for descending sort. The size of the icon indicates the significance of the variable in the sort.

Sorting is not available if the dataset is open in *Edit* mode. If you attempt to switch to *Edit* mode while a sort is currently active, the entire dataset to be rewritten to match the current sort order, to allow it to be edited in-place.

To sort a dataset:

1. Right click the column header for the variable that you want to use as the primary key.
2. Click either **Ascending Sort** or **Descending Sort** on the shortcut menu to perform the sort.
3. You can add further keys to the sort by selecting the required column and clicking either **Ascending Sort** or **Descending Sort**.
4. Optional:

   You can clear any of the sorts by using the **Clear Sort** option on the shortcut menu.

---

<table>
<thead>
<tr>
<th>Criteria</th>
<th>Expression</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td>Not between (inclusive)</td>
<td>NOT BETWEEN ([x]\ AND ([y])</td>
<td>Is not between 100 and 200</td>
</tr>
<tr>
<td></td>
<td>BETWEEN 100 AND 200</td>
<td></td>
</tr>
<tr>
<td>Is missing</td>
<td>IS MISSING</td>
<td>IS MISSING</td>
</tr>
<tr>
<td>Is not missing</td>
<td>IS NOT MISSING</td>
<td>IS NOT MISSING</td>
</tr>
<tr>
<td>In</td>
<td>IN ([x], [y]) OR IN ([s1], [s2])</td>
<td>Is one of the values 100, 200 or 300</td>
</tr>
<tr>
<td></td>
<td>IN (100,200,300)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>IN (&quot;Blanco&quot;,&quot;Jones&quot;,&quot;Smith&quot;)</td>
<td></td>
</tr>
<tr>
<td>Starts with</td>
<td>LIKE &quot;s%&quot;</td>
<td>Starts with the string &quot;Bla&quot;</td>
</tr>
<tr>
<td>Ends with</td>
<td>LIKE &quot;%s&quot;</td>
<td>Ends with the string &quot;nco&quot;</td>
</tr>
<tr>
<td>Contains</td>
<td>LIKE &quot;%s%&quot;</td>
<td>Contains the string &quot;an&quot;</td>
</tr>
</tbody>
</table>
Working with program output

Output from programs is accessible from the following views:

- **WPS Server Explorer** (page 52) – Provides access to the datasets, catalogs, library references (for example, the default Work library), file references, and so on, generated for the particular server.
- **Output Explorer** (page 59) – Provides access to the logs and output generated by the Output Delivery System (ODS), such as the listing, HTML or PDF output formats.
- **Results Explorer** (page 59) – Provides access to the output results of procedures run as part of the SAS language program.
- **Outline** (page 58) – Provides access to the structural elements of the currently selected program, log, listing or HTML output.

Log output for a server is cumulative and shows information and errors from each program that has been run during the current session.

Listing output is cumulative for a server and shows the results of every program that has been executed during the current session.

HTML and PDF output show the results of the programs, but neither are cumulative.

The WPS server itself can be restarted without restarting Workbench (see *Restart the server* (page 33) for more information). This clears the log, listing and HTML output, and deletes temporary files library references, datasets and macro variables set up on the server.

### Dataset generation

If your program produces or amends a dataset, then this can be viewed from the relevant library in WPS server explorer.

For example, each time you run the following sample program the associated dataset is updated in the Work library:

```plaintext
DATA longrun;
  DO I = 1 TO 5000000000;
    OUTPUT;
  END;
RUN;
```

To view the details associated with the dataset, in **WPS Server Explorer** view, expand the **Work** library under the **Local** server, right-click on the dataset name and click **Properties** on the shortcut menu.

For more information about the use of libraries on a server, see *Libraries and datasets* (page 76). For details about viewing and amending datasets, see *Dataset Viewer* (page 91).
Logs

The log output contains the a record of events occurring during the execution of a SAS language program.

The log file contains a record of activity for the current WPS server session. If multiple programs are executed on the same server during a single server session, the output for all programs is appended to the same log.

To reset the log, click the WPS menu, click Clear Log and then click Local Server (or the name of the server you have run your programs on).

If you have more than one WPS server registered in the Workbench, each WPS server creates to its own log file.

View the log

To display the information contained in the log:

1. In the Output Explorer view, click the arrow next to the required server to display output files for that server.
2. Double-click the Log to open the log file in the Editor view.

If you have run several programs, log information for all programs is concatenated into a single log file. To help locate information, you can use the Outline view to navigate the log, see the Outline view (page 58) for more information.

Save the log to a file

To save the log to a file:

1. In the Output Explorer view, click the arrow next to the required server to display output files for that server.
2. Double-click the Log to open the log file in the Editor view.
3. Click the File menu and then click Save As. Use the Save As dialog box to save the file to the required location.

Print the log

To print the log for a particular server:
1. In the **Output Explorer** view, click the arrow next to the required server to display output files for that server.

2. Double-click the **Log** to open the log file in the **Editor** view.

3. Click the **File** menu and then click **Print**. Use the **Print** dialog to send the log to your required printer.

---

**Log colouring preferences**

You can control the visual preferences for items (errors, notes, warnings, and so on) displayed in a log file using the **Log Syntax Coloring** page of the **Preferences** window.

For each item type, you can specify attributes for **Colour**, **Background Colour**, and whether the item should be displayed in **Bold**.

---

**Managing ODS output**

Once you have run a program that produces some output using the ODS (Output Delivery System), you can view it in the **Results Explorer** view.

The ODS destinations and the location of the generated output, can either be automatically managed by Workbench, or controlled through statements in the SAS language program.

---

**Automatically manage ODS destinations**

Preferences to control the ODS destinations automatically created when a SAS language program is run in Workbench. To output the ODS destinations in a program not running in Workbench, you will need to add the required ODS creation statements to your program.

**Automatically Manage Result Types**

- Click **Yes** to create ODS destinations for each of the result types selected. Click **No** to manage the output within the SAS language program.

**Result Types**

Select the ODS destination to be automatically created. Workbench creates a temporary file for each destination type for each SAS language program run. When a different program is run, or the same program run again, new temporary files are created.

**Show generated injected code in the log**

Click to show the automatically created code for each ODS destination in the log output.
Listing output

This section of the guide looks at the listing output of results.

Listing Colouring Preferences

The preferences that you can set regarding the different items contained in listing results are found under Window ➤ Preferences… ➤ WPS ➤ Listing Syntax Coloring:

For each different type of item contained in a listing, you can specify attributes for Colour, Background Colour, and whether or not the item should be displayed in Bold.

View the listing output

To view the listing output:

1. Ensure you have the Output Explorer open (Window ➤ Show View ➤ Output Explorer).
2. If there is more than one server, open the required server node to display the associated output.
3. Either double-click the Listing node, or right-click it and select Open from the context menu.

The listing output opens and is given focus.

If you have performed several runs, the previous listing output will be concatenated into the existing results. If you want to clear the output, to ensure that when you next run a program the listing only contains results for that run, then you can proceed in accordance with either of the following:

- Clearing the results output (page 105) (which will also clear any HTML output (page 102)).
- Restart the server (page 33) (which will clear the log and all results, datasets, library and Filerefs).

Navigating the listing output

If you have executed several programs, or several instances of the same program, and have not cleared the results for the particular server by either Clearing the results output (page 105) or Restart the server (page 33), then each instance of listing output will have been appended to the existing listing file in order of execution.

To navigate the output contained in the listing file:

1. Open the results in accordance with View the listing output (page 101).
2. Ensure that you have the Outline view open (Window ➤ Show View ➤ Outline).

3. In this view you will see nested output for the various programs, with nodes for the different output elements. Click on any of these nodes and the corresponding section in the listing file will be displayed.

**Saving the listing output to a file**

To save the listing output to a file:

1. Ensure that you have the Output Explorer open (Window ➤ Show View ➤ Output Explorer).

2. Do one of the following:
   - Right-click on the Listing node, and, from the context menu, select Save As....
   - Open the listing in the editor (see View the listing output (page 101)), and then right-click in the editor window and select Save As....
   - Open the listing in the editor and then select File ➤ Save As... from the main menu.

3. Use the Save As dialog to save the file to the required location.

**Printing the listing output**

To print the listing output for a particular server:

1. Ensure that you have the Output Explorer open (Window ➤ Show View ➤ Output Explorer).

2. If there is more than one server, open the required server node to display the associated output.

3. Do one of the following:
   - Right-click on the Listing node, and, from the context menu, select Print Results....
   - Open the listing in the editor (see View the listing output (page 101)), and then right-click in the editor window and either select Print... or press Ctrl+P on Windows (Cmd-P on MacOS).
   - Open the listing in the editor and then select File ➤ Print... from the main menu.

4. Use the Print dialog to send the results to your required printer.

**HTML output**

This section of the guide looks at the HTML output of results.
Viewing the HTML output

To view the HTML output:

1. Ensure you have the Output Explorer open (Window ➤ Show View ➤ Output Explorer).
2. If there is more than one server, open the required server node to display the associated output.
3. Either double-click the HTML node, or right-click it and select Open from the context menu.

The HTML output file opens and is given focus.

Navigating the HTML output

If you opted to have the HTML output automatically managed by the Workbench (see Automatically manage ODS destinations (page 100)), then each run will create a new HTML file. However, if you have executed several programs, or several instances of the same program, and have not cleared the results for the particular server by either Clearing the results output (page 105) or Restart the server (page 33), then the previous HTML output will still be available in the Outline (page 58) view.

To navigate the output contained in the HTML file:

1. Open the results in accordance with Viewing the HTML output (page 103).
2. Ensure that you have the Outline (page 58) view open (Window ➤ Show View ➤ Outline).
3. In this view you will see nested output for the various programs, with nodes for the different output elements. Click on any of these nodes and the corresponding section in the HTML output will be displayed.

Printing the HTML output

To print the HTML output:

1. Ensure that you have the Output Explorer open (Window ➤ Show View ➤ Output Explorer).
2. If there is more than one server, open the required server node to display the associated output.
3. Do one of the following:
   - Right-click on the HTML node, and, from the context menu, select Print Results....
   - Open the HTML file in the editor (see Viewing the HTML output (page 103)), and then right-click in the editor window and either select Print... or press Ctrl+P on Windows (Cmd-P on MacOS).
   - Open the HTML file in the editor and then select File ➤ Print... from the main menu.
4. Use the **Print** dialog to send the results to your required printer.

**Note:**
A single HTML output file is created for each run within the Workbench. However, you can only print the HTML output of one run at a time.

**PDF output**

This section of the guide looks at the PDF output of results.

To set up the automatic management of PDF output, refer to *Automatically manage ODS destinations* (page 100).

The **default** settings for PDF output are as specified in the `wps.cfg` file (see *Configuration files* (page 115)), and are as follows:

- `-BOTTOMMARGIN 1cm`
- `-LEFTMARGIN 1cm`
- `-RIGHTMARGIN 1cm`
- `-TOPMARGIN 1cm`
- `-ORIENTATION portrait`

The **PAPERSIZE** is determined automatically by the locale of WPS Workbench (see *WPS server LOCALE and ENCODING settings* (page 23)). It can be reset using unmanaged output (see below).

The **startpage** option, which determines whether or not the output from each PROC starts on a new page, is not configurable inside WPS Workbench. It is initially set to `STARTPAGE=yes` in the ODS software, which means that each PROC does start on a new page. The option can also be reset using unmanaged output (see below).

You create unmanaged output by entering code directly into your programs, as per the example below:

```plaintext
options orientation=landscape;
options papersize=A4;
options topmargin=0.75in;
options bottommargin=0.5in;
options leftmargin=0.5in;
options rightmargin=0.5in;
ods pdf
  file="body.pdf"
  startpage=no;
  /* Startpage=no means that new pages are not generated between PROCs */
  /* Insert PROCs to generate output */
o_ds_all_close;
```

**Note:**
Relevant parts of the code can also be used as WPS code injections (page 69).
Clearing the results output

1. To save your output before clearing it, save your PDF elsewhere if you have been using the PDF destination, or proceed as in Saving the listing output to a file (page 102).

2. Clear the output results for the required server by doing one of the following:

   - From the main menu, select WPS ➤ Clear Results ➤ Local Server (or substitute the name of your remote WPS server in place of Local Server).

   - Use the keyboard shortcut Ctrl + Alt + O to remove the results from the default server.

   **Note:**
   If you have more than one WPS server registered, then the above action will clear the results for the Default WPS server (page 23). If in doubt as to which is the default server, use the tooltip for the toolbar button to show which server’s results will be cleared.

   - From the toolbar, click to clear the results from the default server, or click the drop-down next to this button to select a non-default server.

   - Ensure that you have the Output Explorer open (Window ➤ Show View ➤ Output Explorer), right-click on the listing output, HTML output or PDF output for the required server, and from the context menu, select Clear All Results.

All output will now be blank.

**Note:**
The effects of this option are different from Restart the server (page 33) in that you preserve the context of what you are currently doing, and do not lose your temporary work.
Text-based editing features

You can use these features with the SAS Editor (page 107) to help you write and modify programs and other project files. The same features are available with the Text Editor (page 108), with the exception of Colour Coding of Language Elements. These features are not available when managing files through the File Explorer view.

Left hand borders

The left hand borders are used to display different features:

• In the outer left grey border, you will see annotations.
• In the inner left white border, you will see the expand and collapse controls for blocks of related language items. The white border is also used to display quick difference indicators.

Annotations

These can consist of the following displayed in the outer left grey border of a file:

• Bookmark anchors (page 56)
• Task markers (page 57)
• Search results

Quick difference indicators

A quick difference indicator in the inner left white border of a program shows that something has changed in that line of code since it was last saved:

• Indicates that a change has been made to the line of code.
  
  If you hover the mouse over this coloured block, a popup window will show you the code as it was prior to the change.
• Indicates that there is a new, additional line of code.
• Indicates the position where one or more lines of code have been deleted.

When you save a program, the quick difference indicators will be cleared from the margin.

Navigating between annotations and quick difference indicators

You can navigate between annotations within an individual program by using the Navigate menu options. The Next option moves to the next annotation, the Previous option moves to the previous annotation.

You can also use Next Annotation and Previous Annotation on the Workbench’s main button bar to move between annotations and quick difference indicators.
Layout preferences

The display controls for a program, including the current line, foreground and background colours, and whether to display line numbers, are user defined. See Text Editor Preferences (page 109) for more details.

Colour Coding of Language Elements

The colours used to display language elements in a program can be controlled via the Preferences. See WPS Syntax Colouring (page 70) for more information.

Working with editors

In any Workbench perspective you use, the Editor window is always displayed so that you can continue to write and modify files. This section describes the various ways of opening files in the Editor window with the different editors.

Only one file can be active at any one time. This is the file that currently has focus within the Editor window.

You can open programs using either the Project Explorer view or File Explorer view. The Project Explorer view offers more control than the File Explorer view, which determines the most suitable editor automatically, based on the filename extension of the file being opened.

Editing files within projects allows you to use local history to help you manage changes. See Local history (page 40) for more information.

SAS Editor

The SAS Editor view provides features suitable for editing SAS language programs, such as syntax colouring.

Programs can be opened either via a project or directly from one of the available file systems. Only files with an extension .wps or .sas can be opened in this editor.

To open a program in the SAS Editor view:

1. Click the Window menu, click Show View and then click Project Explorer.
   
   If you are using the File Explorer view, Click the Window menu, click Show View and then click File Explorer.

2. Navigate to the program you want to open and double-click on the program name.
Text Editor

The Workbench has a basic Text Editor view. You can open a program with this editor but the contents are treated as regular text file.

To open a file in the Text Editor view:

1. Click the Window menu, click Show View and then click Project Explorer.

   If you are using the File Explorer view, Click the Window menu, click Show View and then click File Explorer.

2. Navigate to the file you want to open. If the file is a text file, then double-click on it. Otherwise, right-click on the file, and, from the context menu, select Open With ➤ Text Editor.

System Editor

If a file has an extension associated with an application installed on your computer (for example, .doc may be associated with Microsoft Word), the System Editor will launch that application with the file in a new window outside the Workbench.

To open a file with the System Editor:

1. Click the Window menu, click Show View and then click Project Explorer.

   If you are using the File Explorer view, Click the Window menu, click Show View and then click File Explorer.

2. Navigate to the program you want to open and double-click on the program name.

In-Place Editor

The Workbench supports OLE (Object Linking and Embedding) document editing. For example, if you have a Microsoft Word document in your project and use the In-Place Editor, the Word document will open in the Workbench's Editor (page 55), with Microsoft Word's pull-down menu options being integrated into the menu bar of the view.

To open a file with the In-Place Editor:

1. Click the Window menu, click Show View and then click Project Explorer.

2. Right-click on the required file, click Open With and then click In-Place Editor on the shortcut menu.

   If the file has an associated OLE editor, the file is opened in the In-Place Editor in the Editor view and the menus and options associated with the linked application are available.
Text Editor Preferences

You can control the text editor preferences using the Text Editors page of the Preferences window:

1. Click the Window menu and then click Preferences.
2. In the Preferences window, expand the General group, expand the Editors group and select the Text Editors group.

You can use the preferences to determine how programs are displayed in the SAS language editor and the text editor. For example, to set the background colour, in the Appearance colour options, select Background colour, clear System Default, and then select the required Colour.

These preferences only apply to files opened within the Project Explorer view.

Some of the Preferences that can be configured are:

- **Undo history size** – The number of operations able to be undone.
- **Displayed tab width** – the width of the tab used in files
- **Show line numbers** – whether line numbers are displayed in the margin
- **Colours** – current line, foreground, background, and so on.

Closing files

Any file that is opened in the Editor view has a tab labelled with the file name. To stop displaying the file in the Editor view click the File menu and then click Close. Alternatively click Close on the tab.

Jumping to a particular project location

You can jump to a particular location in a project file:

**To jump to a bookmarked location:**

1. Open the Bookmarks view (Window ➤ Show View ➤ Bookmarks).
2. Either double-click on the required bookmark description, or right-click on it, and, from the context menu, select Go To.
3. The relevant file will then be opened (if it was closed), and the bookmarked line will be highlighted (or else the first line in the file if the entire file was bookmarked).

**To jump to a task:**

1. Open the Tasks view (Window ➤ Show View ➤ Tasks).
2. Either double-click on the required task description, or right-click on it, and, from the context menu, select Go To.
3. The relevant file will then be opened (if it was closed), and the line containing the task will be highlighted.

To jump to a particular line number:
1. Select Navigate ➤ Go to Line....
2. Enter the required number in the Go to Line dialog.
3. Either press Enter on your keyboard, or click OK, to complete the operation and close the dialog.

To jump to the last edit:
1. Select Last Edit Location from either the toolbar or Navigate menu.

The relevant file will be opened (if it was closed), the last line you edited will be highlighted, and the cursor will be placed at the end of the last piece of text you edited.

Navigation between multiple project files

You can have as many projects open in the Workbench as you like and each of these projects can contain any number of programs.

You can open any number of programs and other files from the different projects in the Editor (page 55). For each program that is open, a corresponding tab is displayed. An open program can be given focus in the Editor window by clicking on its tab.

Moving backwards and forwards between programs

The main menu options Navigate ➤ Back and Navigate ➤ Forward (or and on the toolbar) are analogous to the back and forward buttons on a web browser. However, unlike a web browser, when you close and re-open WPS Workbench, it still has the navigational information.

• Back navigates to the previous resource that was viewed in the Editor window.
• Forward displays the program that was active prior to selection of the previous Back command.

Searching and replacing

You can find any text string in an open program, as follows:

1. Ensure that the program to be searched is open in the File Explorer (Window ➤ Show View ➤ File Explorer).
2. Display the **Find/Replace** dialog by either selecting **Edit ➤ Find/Replace...** from the menu, or pressing **CTRL + F** on your keyboard.

The **Find/Replace** dialog is displayed, which allows you to specify the term to be found, and, if required, the term with which it is to be replaced.

**Note:**

The default **Scope** is **All**, which means that the whole file is searched (you can amend this to **Selected lines** if required). The other options are those that you would expect to find in any search dialog and are self-explanatory.

3. Click **Find** to find the first instance of the word and then proceed as required, clicking **Find** to move to each new instance of the text string.

**Note:**

If you select **Close** to remove the dialog, then the string is remembered, and selecting **Edit ➤ Find Next** and **Edit ➤ Find Previous** will conduct the same search, forwards and then backwards, without re-opening the dialog.

---

**Undoing and redoing your edits**

There is a multiple undo facility for project file edits, as follows:

1. Either select **Edit ➤ Undo** from the menu, or press **CTRL + Z** on your keyboard.

   The last change you made is undone.

2. Repeat the above step for each previous edit that you want to undo.

**Note:**

The number of undo actions that can be performed is determined by **Undo history size** in the Text Editor Preferences (page 109).

**Note:**

You can also redo any undone edits on an incremental basis, by either selecting **Edit ➤ Redo** from the menu, or pressing **CTRL + Y** on your keyboard, the requisite number of times.
Preferences

There are many user settings, controls and defaults that you can control using the Preferences window. To open the window, click the Window menu and then click Preferences.

Any preferences that are not described in this guide can be looked up in the Eclipse-specific Workbench User Guide.

The Preferences window has a filter function that can help you find preference pages quickly. Once you have opened the window, you will see the filter at the top of the preferences list.

General preferences

The General page of the Preferences window contains controls that affect general aspects of WPS Workbench.

Always Run in Background
Specifies that long running tasks to be run without displaying the Executing window. This allows you to carry on using Workbench for other tasks.

Show Heap Status
When selected, an indicator is displayed in Workbench showing information about usage of the current Java heap memory used by the Workbench interface. This indicator appears in the bottom of the window to the left of the server status.

To increase your Java heap storage, modify the workbench.ini in the eclipse folder of your installation, to, for example, -vmargs -Xmx1024m. This sets the maximum Java heap value of 1024 megabytes.

Workbench save interval (in minutes)
Specifies how often the state of the Workbench, including perspective layouts, is automatically saved to disk. Set to 0 (zero) to disable automatic saving.

Open Mode
Specifies the method used to open objects in Workbench.

- Double click – open an object with a double-click, select by single click.
• **Single click (Select on hover)** – Open an object with a single click, select by hovering the mouse cursor over the resource.

• **Single click (Open when using arrow keys)** – Open an object with a single click, select by hovering the mouse cursor over the resource. When you use the arrow keys to open an object with a single click, Selecting a resource with the arrow keys will automatically open it in an editor.

### Change shortcut key preferences

Workbench provides shortcut key mappings for the most commonly-used commands. You can modify these mappings, or create new mappings.

To change a shortcut key mapping:

1. Click the **Window** menu and then click **Preferences**.
2. In the **Preferences** window, expand the **General** group and select **Keys**.
3. Either type the command name, for example **Cancel edits** in the filter, or select the required command in the list.
4. Select **Binding** and type the shortcut key, for example **Ctrl+5**.
5. If no conflicts are reported, click **OK** to save the new mapping.

To delete a binding, select the required command and click **Unbind Command**.

### Back up Workbench preferences

Save your current preferences to file to preserve preferences or to import into a different Workbench installation.

To save your preferences to file:

1. Click the **File** menu and then click **Export**.
2. In the **Export** dialog, expand the **General** group and click **Preferences**.
3. Click **Next** and in the **Export Preferences** page, select the required preferences and enter a preference filename.
   
   If you are updating an existing file, you can select **Overwrite existing files without warning** to avoid warning dialogs during export.
4. Click **Finish** to create the backup file.
Import Workbench preferences

Import saved preferences from file to a Workbench installation.

To import preferences from file:

1. Click the **File** menu and then click **Import**.
2. In the **Import** dialog, expand the **General** group and click **Preferences**.
3. Click **Next** and in the **Import Preferences** page, select the required preferences file and choose the preference group to import. and enter a preference filename.
4. Click **Finish** to import the preferences.
Configuration files

Configuration files are files incorporating system options that control the initial WPS environment. Configuration files are used during WPS initialisation when WPS is run from the command line, and also when the Workbench is being used.

You can open a configuration file as a basic text file in order to add, remove or change system options to suit your needs.

There is a base configuration file that is included with the WPS installation, called \texttt{wps.cfg} and it is located in the directory where WPS is installed. It is recommended that this file be left untouched and one of the override mechanisms below be used if any modifications need to be made.

\textbf{Note:}
A number of configuration files can be processed during WPS initialisation, each of which may set some of the same options. If an option is set in more than one place, the last one processed will have precedence. Options set on the command line, or options set in the \textbf{Startup Options} configuration panel for a server, will override any settings that are set in the configuration files.

\textbf{WPS initialisation procedure for Windows}

When WPS is invoked, the following initialisation procedure occurs:

1. The \texttt{WPS\_SYS\_CONFIG} operating system environment variable is evaluated and, if it exists, the specified configuration file is processed. The processing of this file does not affect whether the default configuration files are loaded.

2. Any files specified via the \texttt{-config} option on the command line or in the startup options for a server are processed.

   If any configuration files are specified via the \texttt{-config} option, the default configuration files are not loaded, and the \texttt{WPS\_USER\_CONFIG} is processed instead.

   Take care when overriding the default configuration file processing, specifically the loading of the \texttt{wps.cfg} file. There are many required options in the base \texttt{wps.cfg} file. If you use the \texttt{-config} option, it is recommended that you either take a copy of the base \texttt{wps.cfg} file and modify it to suit, or that you make sure to include the base \texttt{wps.cfg} file in your custom configuration file and then override any settings that you need, for example:

   \begin{verbatim}
   -set wpshome 'somewhere'
   -config !wpshome/wps.cfg
   /* And now set any options you want */
   \end{verbatim}

3. The default configuration files are processed in the following order:

   a. \texttt{wps.cfg} in the WPS installation directory

   b. My Documents/My WPS Files/.wps.cfg

   c. My Documents/My WPS Files/wps.cfg
d. My Documents/My WPS Files/.wpsv3.cfg

e. My Documents/My WPS Files/wpsv3.cfg

f. wps.cfg in the current directory

g. wpsv3.cfg in the current directory

4. The **WPS_USER_CONFIG** environment variable is evaluated and, if it exists, the specified configuration file is processed.

5. The **WPS_OPTIONS** environment variable is evaluated and, if it exists, any options specified are processed. The syntax of this environment variable is the same as if the options are specified on the command line.

6. Any options specified on the command line are processed.

WPS initialisation procedure for UNIX platforms

When WPS is invoked, the following initialisation procedure occurs:

1. Any files specified via the `-config` option on the command line or in the startup options for the server are processed.

   If any configuration files are loaded in this way, the default configuration files are not loaded.

2. The **WPS_OPTIONS** and **WPS_V3OPTIONS** environment variables are evaluated and any contained `-config` options are processed.

   If any configuration files are loaded in this way, the default configuration files are not loaded.

   **Note:**
   This step is skipped if the `-NOCONFIG` option is specified on the command line.

3. The **WPS_CONFIG** and **WPS_V3CONFIG** environment variables are evaluated and, if they exist, the specified configuration files are processed.

   If any configuration files are loaded in this way, the default configuration files are not loaded.

   **Note:**
   This step is skipped if the `-NOCONFIG` option is specified on the command line.

4. If no configuration files have yet been loaded, the default configuration files are loaded in the following order:

   a. wps.cfg in the WPS installation directory

   b. wps_local.cfg in the WPS installation directory. This file can be edited to provide site-specific overrides of various options.

   c. .wps.cfg in your home directory

   d. wps.cfg in your home directory

   e. .wpsv3.cfg in your home directory

   f. wpsv3.cfg in your home directory

   g. wps.cfg in the current directory
h. `wpsv3.cfg` in the current directory

5. The `WPS_OPTIONS` environment variable is evaluated and, if it exists, any options specified are processed. The syntax of this environment variable is the same as if the options are specified on the command line.

6. The `WPS_V3OPTIONS` environment variable is evaluated and, if it exists, any options specified are processed. The syntax of this environment variable is the same as if the options are specified on the command line.

7. Any options specified on the command line are processed.

There are also "restricted" configuration files that will always be processed. Any options in these files cannot be changed by any other method. The files are based on the user's `userid` and `groupid`. For example, if the user is `<user>` and the group is `<group>`, the following configuration files will be processed:

1. `misc/rstropts/rwps.cfg` in the WPS installation directory
2. `misc/rstropts/groups/<group>_rwps.cfg` in the WPS installation directory
3. `misc/rstropts/users/<user>_rwps.cfg` in the WPS installation directory

Get information about the startup procedure

It is possible to check which configuration files have been processed by checking the `CONFIG` system option. You can do this by invoking a `PROC OPTIONS` statement as follows:

```plaintext
PROC OPTIONS OPTION=CONFIG;
RUN;
```

You can also set the `VERBOSE` system option on the command line, or in the startup options for the server, and WPS will then generate information in the normal log output indicating which configuration files were processed and which system options were set.
AutoExec file

An AutoExec file containing SAS language statements or a program that is automatically executed when the WPS server is started, or restarted from Workbench. The file can be used for a number of purposes, such as setting up common LIBNAMES so that they do not need to be added to every program that is run.

Windows

The WPS server automatically runs a file called autoexec.sas. The WPS server searches for the autoexec.sas file in the following directories, in the order shown:

1. The current directory
2. My Documents in your user profile
3. Paths specified in the PATH environment variable
4. The root directory of the drive, for example C:\
5. The WPS installation directory.

Other operating systems

The WPS server automatically runs a file called autoexec.sas. The WPS server searches for the autoexec.sas file in the following directories, in the order shown:

1. The current directory
2. Your user home ($HOME) directory
3. The WPS installation directory.

Specifying a different file

To automatically run a different file, or a file not in the searched directory hierarchy, set the AUTOEXEC system option to point to the file (see Configuration files (page 115)).

You can also set the AUTOEXEC system option through Workbench:

1. In the WPS Server Explorer view, right-click the server name and click Properties from the shortcut menu.
2. In the Properties list, double-click Startup, click System Options.
3. On the System Options panel, click Add.
4. In the Name field, enter AUTOEXEC, and in the Value field enter the path to the required configuration file and click OK.
5. Click OK on the Properties dialog and you will be prompted to restart the server.
WPS Tips and Tricks

WPS Setup

- Use WPS Link connect to a remote server solution and run SAS language programs (see Connect to a remote WPS server (page 48)).
- You can change the Workbench font, background appearance, or change the shortcut key bindings (see Preferences (page 112)).
- You can export and import preferences (including templates) between workspaces.
- You can use configuration files to control the system options used in the WPS environment (see Configuration files (page 115)).
- You can use an AutoExec file to set up common LIBNAME statements and use them any program running on the WPS server (see AutoExec file (page 118)).
- You can define multiple servers the same machine and distribute programs between those servers (see Define a new WPS server (page 51)).

File Management

- To display or create a different group of projects, you can switch to a different workspace (see Switching to a different workspace (page 43)).
- You can restore a file deleted in the Project Explorer from the project's local history (see Restore from local history (page 42)).
- You can use the Project Explorer to compare and merge files (see Comparing and merging multiple files (page 39)).
- You can create directory shortcuts in the File Explorer to access files on the host file system (see Create a new remote host connection (page 48)).

Running SAS language programs

- You can specify code that is to be executed automatically before and after each program (see WPS Code Injection (page 69)).
- You can create templates containing code snippets that can be re-used (see Entering WPS code via templates (page 69)).
- You can run part of a program from the Workbench (see Run part of a program (page 71)).
- You can control whether or not the ODS destinations are to be controlled automatically, and, if so, which specific types of output are to be used (see Automatically manage ODS destinations (page 100)).
• You can set a permanent location for the WORK library to preserve datasets when Workbench is closed (see Set WORK location (page 76)).

Datasets
• You can edit datasets from within the Workbench, using in-place context-aware editing and column re-ordering.
• You can export datasets as delimited and fixed width text, and also as Microsoft Excel spreadsheets.
Troubleshooting

The following is a list of potential problems and how to resolve them:

**Why are the icons greyed out so that I cannot run any programs?**

The icons will be greyed out if:

- The server on which you are running programs is not licensed or has been uninstalled. See [WPS server](page 21) for more information.
- The name of the program file open in the Editor view does not use the .sas or .wps file name extension.
- The focus of the mouse is in a view other than the Editor view.

**Why do I see a dialog saying that there is no default server on which to submit the program?**

Usually because the default WPS server has been removed. If you have other WPS servers defined, select one of those as the new default (see [Default WPS server](page 23)). Alternatively, you can restore the WPS server that was removed (see [Define a new WPS server](page 51)) and set it as the default.

**Why are the characters in my files not being displayed correctly?**

This is likely to be an encoding issue. You should follow all the steps in [WPS server LOCALE and ENCODING settings](page 23) and [General text file encoding](page 24), and restart Workbench. If you have imported the files that are displayed incorrectly, then you may need to re-import them.

**Why can’t I start the Workbench?**

If the Workbench usually starts, but then fails, you may have run out of disk space, causing one or more files in the workspace .metadata directory to become corrupted. Rename the .metadata folder in the corrupt workspace directory to something else, restart WPS, and select to the workspace again. The Project Explorer contains no entries, but the project content and location are unaffected. You can reimport any existing projects as required. See [Import a project](page 16) for more information.

**How do I increase my Java heap storage in the event of Java Runtime errors?**

You can set the -Xmx and -Xms Java options to change the amount of heap memory available to the Java Runtime. See [Show Heap Status](page 112) for more information.
Making technical support requests

How you access technical support for your WPS software depends on how you purchased your software. If you made a standard purchase of WPS software you have an annual subscription licence that entitles you to unlimited free upgrades throughout the twelve months, and free email support via support@worldprogramming.com.

Larger customers may have additional support arrangements in place. In this case, the handling of technical support requests may be carried out via one or more super users in your organisation – you need to be aware who the super users are to progress support issues.

Due to the complex nature of the SAS language, extended interaction between World Programming and yourselves may be required to identify and resolve the issue. Resolutions to problems may include suggested workarounds or may require you to update your WPS software installation.

WPS server log files

For certain types of issue, you may be requested to provide the log file. If the log is open in Workbench, right-click on the view and click Save as from the shortcut menu. If the log is not open, the .log file is stored in the .metadata directory in the active workspace.

Because .metadata and .log start with a period, they will normally be hidden and you will need to ensure you can see these types of file.
Legal Notices


All rights reserved. This information is confidential and subject to copyright. No part of this publication may be reproduced or transmitted in any form or by any means, electronic or mechanical, including photocopying, recording, or by any information storage and retrieval system.

Trademarks

WPS and World Programming are registered trademarks or trademarks of World Programming Limited in the European Union and other countries. (r) or ® indicates a Community trademark.

SAS and all other SAS Institute Inc. product or service names are registered trademarks or trademarks of SAS Institute Inc. in the USA and other countries. ® indicates USA registration.

All other trademarks are the property of their respective owner.

General Notices

World Programming Limited is not associated in any way with the SAS Institute.

WPS is not the SAS System.

The phrases "SAS", "SAS language", and "language of SAS" used in this document are used to refer to the computer programming language often referred to in any of these ways.

The phrases "program", "SAS program", and "SAS language program" used in this document are used to refer to programs written in the SAS language. These may also be referred to as "scripts", "SAS scripts", or "SAS language scripts".

The phrases "IML", "IML language", "IML syntax", "Interactive Matrix Language", and "language of IML" used in this document are used to refer to the computer programming language often referred to in any of these ways.

WPS includes software developed by third parties. More information can be found in the THANKS or acknowledgments.txt file included in the WPS installation.